Chromium fails to launch

Anyone else seeing this? Latest stable release for Linux, v 90.0.4430.93
Apr 26, chromium_1568.snap Apr 28. I tried removing and then reinstalling it via Software Install - no diff. Then tried $ sudo snap refresh --edge chromium to download and install chromium (edge) 92.0.4496.0 [as chromium_1575.snap]. Still won't start. (I'm using Chrome instead.) There are no recent posts re this glitch on the Chromium Project site or elsewhere. Suggestions?

PS - I see Chrome is not picking up recent bookmarks made in Chromium. Why? How do they overlap in this regard?

This thread:

Is there a possible relation? If both are snaps, I wonder if snap itself corrupted.
Have these problems appeared simultaneously of far apart?

Otherwise: it is possible Chromium is failing to launch due to updated fonts not loading. A suggested workaround;
Remove the configuration files and launch:

sudo rm /var/cache/fontconfig/*

rm ~/.cache/fontconfig/*

sudo fc-cache -r -v

rm -rf ~/snap/chromium/common/.cache/fontconfig/


Yes, both are snaps and both just became cranky. But other snaps like gimp and VLC player open fine, so snaps or snapd seem unlikely culprits. Been around the block with both, and am still snookered.

Given how infrequently you post, it is a safe assumption that you are adept at troubleshooting.
If you have been around the block with both and still snookered, it may be that the unlikely culprit is the culprit. I am no expert at snap as I do not use snap - however in this case if it was me, I would try:

sudo apt install --reinstall snapd

Then use snap to reinstall the offending software.