Civ IV on Zorin Core

I was able to install and run Civ IV from a GOG download.
However weird issue is the resource images don't show.
Or rather only bread shows, not the other resources in a given square. Also only the single bread image shows but shows separated if the spot has multiple bread.

Anybody install this and notice/fix the issue?

Hi and welcome to the forum :slight_smile:

I think our gaming specialist volunteers might be able to help you.
@Michel @StarTreker @Storm

1 Like

@FrenchPress, my tutorial does explain everything ;). Specially gog, there is not 1 game that i did not get to work (oke with exception of Star Trek Starfleet Command III)

1 Like

Does it include a linux client from GOG? I know that on Steam it have a linux client.

It uses gog galaxy but not linux native. GOG has their own installers so you don't need gog galaxy (sometimes for online gaming). Users can either chose to download with the client or download by web (installers)

So it uses a layer of wine or Proton?

You can install the client through lutris using the wine layer yes. But for gog i recommend the game installers and set the game up with lutris using the GloriousEggroll runner.

Just to be clear I used the offline download for Civ IV and did not install GOG galaxy. Dunno if that matters.

How do you run it ? Lutris ? What runner do you use ?

Did you install directx and vredist ? Some games need this to run better (some games dont even start if it is not installed)

Graphic card drivers up to date ?

Uninstalling wine and reinstalling new version along with lutris seems to have worked.
I ran it initially with wine. Doesn't look like lutris was even installed initially. Updated wine and lutris and running the game through lutris seems to work perfectly. thank you.

I have marked this thread [Solved].

Well it worked the one time. now it crashed when starting a game but it loads the menu etc. Get error below in log.

System information:
Wine build: wine-6.14.r0.g069adfd1 ( TkG Staging Esync Fsync )
Platform: i386 (WOW64)
Version: Windows 7
Host system: Linux
Host version: 5.11.0-40-generic
wine client error:1fc: write: Bad file descriptor
Monitored process exited.
Initial process has exited (return code: 1280)
Exit with return code 1280

Interestingly enough it runs if I dont run it in lutris and instead run it through the icons under wine in the meu.

WineHQ Bugzilla – Bug 50907 – Civilization 4: No hammers displayed on resource tiles - seems like your issue

You can install d3dx9 using winetricks.
My recommendation is to use PlayOnLinux instead of winetricks. Once POL is installed -> Configure -> Select virtual drive where you installed your game (you can do this even before installing your game) -> Install components.

Although the solution here is on, in the future first look at - in this case I couldn't find it for Civ IV but usually gamersonlinux have better solutions than winehq.

PS - Note that you can even install different versions of wine using POL with Tools -> Manage wine versions.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.