Clean installed Zorin Core on an ASUS E510 which was windows 11 was unable to finish setting it up

while I was in the process of setting it up Zorin identified my printer it was not even on! It gave me the software requirements I needed so I downloaded all of them, which turned out to be a couple of debs and tarballs. along with zorins identification of my brother printer came the instructions needed to expedite the installation. by the next day we're past all that. Now It doesn't recognize the printer and the tailored instructions that were there are now gone. keep in mind when I say it doesn't recognize the printer I haven't installed anything yet. I just want to get back to an OS that's one step ahead of me and have it tell me what to do next. the question is, Is there any way to get it back to the initial install starting point or am I going to have to reinstall and then of course stick with it. so far from what I saw I think it's as good they say it is. I'm impressed.

Have you tried removing the printer from settings and adding it again?

Also, you're all updated to current and such right? When I first installed Zorin, it wouldn't let me access my SMB shares - updated, and was able to get all my resources.

It may be the kernel. Sorry. I updated my reply. Maybe a newer kernel can help?

before i reinstall I will definitely try that, thanks I'm not going to do anything drastic until the weekend so I can have the time needed if necessary

1 Like

Is it a USB printer? If so, you might be good to install 'libusb-dev' via sudo apt install libusb-dev - extra USB support :grin:

I don't even know how to install tarballs or deb. I hope to get to the place where that won't be so daunting.

it is set up on usb with windows 10 desk top the former windows 11 laptop now Zorin will be Wi-Fi. I might need to disconnect the usb for pairing with Zorin.

I'm headed for bed got to get up early I'll check back in tomorrow evening thank you guys..

1 Like

For sure! I'm on east coast time myself, might be a delay in responding haha

With .deb packages, you double click them, the same as you would with an .exe package on Windows.

Tarballs -it would not be often you would need to install from a .tar.gz. But if ever you do, just extract it, open a terminal in that directory and run:



sudo make install

That's it.

What happens with any live desktop or installed OS is that the Linux kernel now recognises the make and model of printer (with the exception of sone newer HP Printers). It states that it has found a "driverless" printer which means you will need to install the Linux driver for that printer. Follow the guide that Team Zorin have provided.


I have tried to extract and install this "linux-brprinter-installer-2.2.3-1.gz" using several different sets of instructions some on YouTube tutorials others just text instruction but all of them to no avail. I may be barking up the wrong tree but all of the information that I've seen involves tarballs. I mean I can extract this gzip without the terminal. if you go inside you will not find tar anywhere. if this is just a gzip would including tar create an error? I may have seen two videos on extracting gz files but absolutely nothing on installing without including tar in it.

Can you link directly to the package in question?
It may be easier if I can look at it.

1 Like

Downloads | MFC-L2690DW | United States | Brother the top driver should be the one I believe

I'm headed outside to take the wall down backside of the house ill be back

1 Like

Why not use the second one down - the Self Installer .deb package?

For the First Option that is the .gz file that lands in your ~/Downloads folder, right click the download, then click extract here
Then in terminal change directory:

cd ~/Downloads

and run the installer file:


1 Like

Are you using this as a shared printer hosting it through your Windows machine?

yes sir it was on my windows 10 and set up with usb. I figured why not go ahead and go wireless with 10 as well so much for that idea it proved to be more of a problem than i realized. this is my first Brother printer. I've had lexmark and hp in the past

That should be fine! It probably won't show up where you'd expect to see it - if you navigate to Settings --> Printers --> Advanced printer settings, and then Add -> Printer - does it populate from the list?

Also check sharing settings on the Windows machine for the printer; that could be causing a hangup as well.

as of right now windows 10 is not even connected to the printer my attempt to go wireless yesterday was unsuccessful and I haven't reinstalled the usb driver for it yet. when I go to Settings --> Printers --> I never found Advanced printer settings. however, I did find additional printer settings and I have three printers showing up its all the same printer merely addtional attempts of trying to get it on board when I try to print a test page a pop up appears at the top of the screen stating the print job was done / completed - all the while the printer remains dormant nothing going on. A message pops up. this print server is not exporting shared printers to the network (keep in mind there is only one printer and as of right now to my knowledge no computer is connected to it. The message continues. Enable the published shared printers connected to this system option in the server settings using the printing administration tool. to start this tool, select system administration, print settings from the main menu.
I do not know how to get there.