Clicking Super Key Open Up both All Application and Start Menu

Hello, first of all i just want to say Zorin OS has been wonderful for my first foray into linux desktop. It's very much customisable. I'm using Zorin 16 Core.

I was changing the appearance from Windows-like (the default) to Touch, which has no Start Menu but All Applications instead. Now, i was just changing it back to Windows-like appearance, but when i press Super key, it shows up BOTH Start Menu and All Applications as shown below:

And when i tried to close the Start Menu by pressing the Super key again, i was greeted with the Overlay (?) menu

I don't want the All Applications menu to show up when i press Super key, just the Start Menu. Can someone help me pointing in the right direction? I can give logs or settings if it's needed

Thank you.

You can mange keyboard shortcuts by going to settings-> keyboard shortcuts. Then disable the shortcut for all application menu from there or change it to something else.

Actually, yeah, it works. I disabled the Show All Applications shortcut which defaulted to Super+A, and it works like a charm.

Thank you.

But i wonder why would it interfere with me just clicking the Super Key? It should only appear when i press Super+A.

2 Likes

I am glad I could help.

Probably a bug, you can try setting it to super+A again and check if it opens by pressing the super key only this time.

In Zorin Settings, (gnome-control-center), there is a setting for using the Super Key for the "start" menu.
I cannot remember off hand and when Zorin OS 16 Lite was released, I was on it like a pack o' dogs on a three legged cat. So I am less able to log into gnome at the moment.
Would you be kind enough to explore Settings and locate that?

Yep, All Applications opened again when i press Super key after i reverted the change. Probably a bug i guess.

1 Like

There is?
I didn't know that...That would have saved a lot of time for me because I had once disabled the shortcut for "start" menu accidentally....I left it that way for days and ended up fixing it when I had to reinstall Zorin because of a much severe problem.

1 Like

Under Zorin Appearance > Interface, there is indeed an option to change Left Super Key default from Activites Overview to Zorin Menu. I had changed it to Zorin Menu when i posted this.

But before i changed it, when i press Super key i get both Activities Overview and All Applications menu in the background.

2 Likes

Yeah and I would be glad if they added the right super key as well.