Clicking top right corner to close window-XFCE

Well, since you found the answer already, this will be a little bit dated, but that was just Google Chrome there that I installed from the Synaptic package manager, if I remember correctly. Firefox would not highlight the X, interestingly enough.

But, this isn't something I ever would have noticed anyway. I never full screen my applications. I have this stupid habit of having a main window open, usually my browser, and then I'll place new windows in locations where an edge is peaking out from behind the browser so I can click on it to bring it to the front. I'm all about inefficiency!

Thank you! Not being able to click the top-right corner of the screen has been an annoyance for me ever since I started using Zorin, but now it works on Firefox and Document Viewer (which opens pdfs). However, it made no difference to other programs like Thunar File Manager, Chromium, the terminal, and LibreOffice. And for gEdit (text editor), it expanded the button to the top of the screen, but not to the far right, so it only partially worked for gEdit.

Any suggestions on how to get ALL programs to implement the same fix? (I have Zorin OS 15.3 Lite.)

Yes, you must change the XFWM theme.
Navigate to the Theme you are using, the to XFWM4 directory.
In themerc, change:

button_spacing=0
button_offset=0

Open the Image files for
top-right-active
top-right-inactive
right-active
right-inactive
in Gimp.
From image on the menubar, select Canvas Resize and shrink the WIDTH ONLY (make sure to click the UNLINK icon) on each of the above files.
Once done properly, go to File, then down where export "overwrite as..."

When the above is done, it will shrink the right edge up to the corner of the screen.

Sorry, I don't quite understand how to do the first step. Under Window Manager, it shows that I'm using the theme ZorinGrey-Dark. How do I find the theme in File Manager and navigate to it?

Edit 1: Ok, I think I found it at /usr/share/themes/ZorinGrey-Dark/xfwm4/.

In the file called "themerc", button_spacing and button_offset were already set to 0. When opening the image files, there is a top-right-active.png and a top-right-active.xpm. Which one should I edit in GIMP?

Edit 2: Well, maybe that wasn't the correct location. Apparently I don't have permissions to modify the images in /usr/share/themes. (I'm still an absolute Linux newbie, so any guidance would be appreciated.)

sudo -i

nautilus

Anytime you move to change any file in ROOT, you must elevate your File Manager to Root Permissions.

Thanks. I used sudo -i thunar, and that let me modify the image files in GIMP. I changed all 4 .png files using the Canvas Size feature, from 9 pixels to 1 pixel. Then overwrote the images, and rebooted. But I don't see any difference in the window icons, and pointing my mouse at the top-right corner of the screen still doesn't highlight the X button to close the window.

Using a different approach, if I switch to the theme called "default-hdpi", then pointing at the top-right corner of the screen DOES highlight the close button, but that new theme wasn't applied to all programs. For example, Document Viewer, Firefox, and gEdit all look the same as if they are still on the ZorinGrey-Dark theme.

I am sorry. I have been mostly fronting Gnome issues, especially since Zorin OS 16 was released. I was on auto-pilot when I typed Nautilus.

This is odd... I had tested this on my own copy before making the suggestion, just to be sure it would work.
Let me try testing it again just to see what went wrong...

CSD applications (Gnome apps) will not display the same as the others because Gnome did away with and removed the Window management and titlebars since they decided we don't need them and don't need user control or choice in the matter, either.
You can patch this by using PCMan's gtk3-nocsd package which breaks the gnomish CSD and forces windows to use the proper window manager.

sudo apt install gtk3-nocsd

Must reboot to see the effect.
This will affect all apps run from Home Level, but not root.
In the meantime, let me see what I can do with the Zorin Theme again.

No problem at all! I figured out what you meant.

Thank for offering to help figure this out! Could there be multiple locations where there are a set of Zorin theme images, and maybe I modified the wrong images?

I installed PCMan's gtk3-nocsd package, which seemed to work. Now all applications have the theme that was selected in Window Manager. However, it does that by adding a whole new titlebar at the top, which takes up a lot more space at the top than before. I generally prefer to maximize my window content-viewing space, so this is not ideal. (And it leaves the old titlebar, so now I have 2 titlebars in Firefox.) See these screenshots to show what I mean.


That is happening in Firefox because Firefox was taught by Gnome it has to manage the Window Management since Gnome refuses to do it anymore.
Open Firefox and tell it that it no longer has to.
Click the Hamburger Icon
More Tools>
Customize Toolbar
At the very, very bottom is a checkbox for Titlebar and it should have no check mark on it. Check that to ON. That is the setting for "Use System Title Bars".

That will solve your problem.

No... it's mostly all in one place except... If you are using Snap Packages or Flatpak packages. Anything installed with those will not follow your standard theme.
Zorin does have Flatpak'ed themes - so you may have cases where a flatpak is using that, instead of your system theme.
The best way to know is; check if you see a difference between apps- like the one in Firefox you noted above.
Then check the source of those packages.