Close lid - fan

Something weird happens when I close the lid. The fan of the computer doesn't turn off :confused:
Thanks for the help

What actions do you have set for when the notebook lid is closed? Is it supposed to sleep, suspend or do nothing?

If processes are still running requiring thermoregulation, the fans may need to stay at speed to protect the hardware from overheating.

Ensure that the notebook is never set on top of a fluffy or insulating surface like a couch, pillow, blanket...
The cooling vent is often placed on the underside of the computer.

Fan Speeds can be managed using the BIOS settings or many native or add-on GnuLinux apps like fancontrol, thinkfan and corefreq... There are many. These should be used with care in case a user is annoyed by loud fans and lowers their speed and overheats their computer, damaging it.
Often, cleaning the cooling vents, fans and heat sink are the preferred action.

Dedicated GPU's, like a Nvidia card can come with their own fans that can be controlled using nvidia-settings.



These are my settings.
I have a new PC, no overheating. Was on windows 11 before, fan turned off when closing lid.

Another problem is when i plug to recharge. It kicks off the fan heavily and i have to stop it.

I don't feel like installing GnuLinux apps that can damage the computer. BIOS settings has nothing for me :confused:
Maybe Nvidia settings? Is it possible to help me?

You might try using a different kernel.

Check which kernel you are on

uname -r

If on Zorin OS 17, I recommend upgrading to the 6.6 or 6.5 kernel. (Ensure Secure Boot is disabled in BIOS Settings):

sudo add-apt-repository ppa:tuxinvader/jammy-mainline

sudo apt update && sudo apt install linux-generic-6.06

If on Zorin OS 16.3, try using the 5.15.0-83 kernel.
You can do this by booting to the Grub Menu and selecting it from the Advanced Options for Zorin - Zorin on 5.15.0-93

1 Like

My kernel : 6.5.0-15-generic

If I type :
sudo apt update && sudo apt install linux-generic-6.06

Won't it be kernel 6.06 and not 6.6 ?

No, it will be kernel 6.6.5. the "6.06" is just TuxInvaders package naming convention... He differentiates the name to avoid name conflicts.

Hum seems like secure boot is still active, so when I install the kernel, it asks me to put some MOK key and when I reboot he asks me for that same key (care of the english keyboard ^^) and then 6.6 kernel does not boot me. I had to go to advanced Zorin options and go for the 6.5 to be able to boot.

How can I disable secure boot? As I don't clearly see the option in BIOS

Are you dual booting with Windows?
If you are not, then you can safely disable Secure Boot. Secure Boot is intended for use with Windows OS that checks a list of signed packages to initialize. GnuLinux works differently and while there is some cooperation by Microsoft signing GnuLinux packages to allow it through Secure Boot, there are plenty of packages that they did not. Secure Boot can be troublesome for Nvidia Packages, as well.

So I'm on 6.6, no difference yet.

If this was me...
I would rollback to the previous working kernel.

Then thoroughly clean my fan intake and output, fan, heatsink, etc.
You can use "Canned air" to blast out any dust.

Brand new PC,
Worked with Windows,

Seems like an easy answer to me...

I also have other problems, but the forum does not let me post more than 1 question at the time.

For example my HDMI connected screen is not detected. Had no problem with Ubuntu for example, nor with Manjaro.

My keyboard has screen brightness hotkeys but it only worked on Windows.

As you can see I have a lot of problems and I hopped that buying 48ā‚¬ a free distribution with promise of support was tempting. Was this a mistake?

If this is Zorin OS 17, it defaults to Wayland. Wayland is troublesome with Nvidia Graphics, for example.
Have you tried logging in with the option Zorin Desktop on X from your log in window?

Users can post separate issues in new threads, so if you need to post a new issue, the forum software should not be inhibiting that ability. If it is, please let us know.

Both of my backlit keyboards are USB and both work OOB with Zorin OS, however, my MB lighting required that I install OpenRGB to control it.
You may need OpenRGB with a notebook keyboard.

Can you give the make and model? The very newest hardware may not have full GnuLinux support. It takes time for the drivers to be moved over to open source.
But just because a PC is new, does not mean it has the newest hardware.

Zorin OS Pro comes with included Installation Support from the ZorinGroup.

Whether you choose the Free version or the Pro, we will all do our very best to be as helpful as we can.
There is a sharp limit on what we know; We rely on the information you provide. And you may need a checklist to even know all the tidbits of information that might help to provide.
Remote support is not easy, with a lot of guesswork and suggestions of things to try and suggestions often made a bit blindly.

If this is a new clean PC and the Fan Speed is normal on Windows OS but immediately running high on Zorin OS, then I agree it is likely a power management issue on Zorin OS rather than a dusty heatsink.
There are plenty of things we can try like grub parameters (acpi_enforce_resources=lax), dfferent drivers, TLP software, lm-sensors... But each step must be taken one step at a time after ensuring the previous steps results.

Thanks for the time you take.

I'm currently on X because another thread suggested it.

Screen brightness hotkeys is the problem, not the keyboard backlight.

I still can return my PC and I feel like it's the best choice, can you tell me if I have to pay again for a new installation of Zorin or it will be with the same account?

Ah, I misunderstood you completely. Sorry about that.

ScreenBrightness Hotkeys are a bane in GnuLinux side because those drivers are most often set by the computer manufacturer, not by Microsoft, Linux or other developers. To this end, they are most often proprietary and this limits what distributions can legally include in their base install.
It makes these hotkeys a common problem for GnuLinux users in general.
However, the user is permitted to install drivers or software to interpret drivers since they are not distributing code or making profit.
I use Brightness Controller to solve this issue:

sudo add-apt-repository ppa:apandada1/brightness-controller

sudo apt update && sudo apt install brightness-controller

No, you would not need to rebuy Zorin OS Pro. Your support code for Zorin OS Pro remains viable for the entire support time (five years) of Zorin OS 17. You can install it on five separate personally owned computers in your home and re-download your copy as many times as you need to.
Using Zorin OS Pro on workplace machines or greater than Five Computers will require a License that can be obtained from the ZorinGroup - but this does not apply to you.
If you deleted your Zorin OS Pro download email, you can use the ZorinWebSite to resend the link.
And if you have lost access to your email account, you can contact the ZorinGroup to change your email account and verify.
So, you are not trapped in Zorin Pro by any means.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.