Colored crash screen when booting up after installation

Are you planning to keep Win10 installed and have a dual-boot setup?

What machine; make / model? Does sound like a graphics driver issue - my main laptop has Nvidia, if I don't install using the 'modern Nvidia drivers' from the installer boot menu, I get similar results..

Also, maybe check the SHA hash on the downloaded .iso file with the Zorin site (here) - could've had some packet drops during the download.

Since the live installation works fine but it crashes on installation, It could be issue with harddrive.
Did you have RAID enabled? If yes change it AHCI

1 Like

Hi, I’m his friend that is trying to install zorin os with dual boot with windows 10. The computer is an HP pavilion all in one with amd A9 or something like that with 6 of ram.

Please help me :pensive:

The installation is fine the problem is when you just start the boot

Do you happen to know what model number? Should be a sticker on it somewhere; if it wasn't removed..

I don't have my Win machine out right now to know specifics - System Information should have it under Summary. Also, take note of what BIOS Mode says. That will pop up in the start menu if you just type in 'system info', should pop up.

And any info on GPU could be relevant as well.

1 Like

Here is the model of the computer and some specifications

Awesome! :+1: Thanks - I'm doing some research on that machine now to see the setup, GPU, etc.

I'll come back to this post and update it when I get something together..

In the mean time - when it boots and you get the garbage screen, does it shutdown or power off? If not, see if you can use Ctrl+Atl+F3 to get to a terminal. If you can get to that terminal, we can see what's going on at boot..

Perfect I will send you a picture just in a sec

1 Like

I entered to root console in the recovery mode and there is a terminal and I found this… :pensive:

The link is to see the picture a problem is that is in Spanish

It looks like you don't have network connection - are you on WiFi or Ethernet?

In the recovery menu, be sure to arrow key to Enable Networking before proceeding to root-drop to prompt if running any prompt commands that will require net connection.

1 Like

I don’t know, but I need to enter to terminal to check my problem right?

For what I was going to suggest looking at, no - but if you wanted to do any apt updates / upgrades, yes. You can reboot and select the recovery root shell with networking if you'd like to give that a shot!

I was going to have you check out /var/log/boot.log for any errors on booting. Use cat /var/log/boot.log to display - it may be a bit lengthy. That will show any errors while the machine is booting, possibly pointing to the issue.

Okay, so that image was from yesterday and what we did was that we also tried to enter recovery mode, Flexi tried to ask chat gpt what to do, and chat gpt told him to update the packages in the terminal, that was yesterday though. He hasn't entered the terminal yet.
I just remembered something we haven't tried yet is booting to the USB, and then selecting the repair option from there.

No, it installs itself fine, when we restart the computer the problem occurs.

Yes, to do what @PlumpKibbles suggested:

The best idea would be to take a photo of each part, to cover the full file. Maybe to get the whole log you can also access the log file using Linux Reader, look for the files, and paste the contents here for better readability.

What's that? He told me he had changed something in the BIOS, but I don't know what it was. I thought it was safe boot or something like that but it was maybe that.

I do want to note I found a similar post today, which had the same issue (also on an HP), and he had the same issue on three of his computers when he updated them. I have two theories about what is going on:

  1. It's a bug in the update that may have stopped some drivers from working, specifically on HP computers.
  2. It's a problem with the download servers, which might be downloading a corrupted ISO file. It's unlikely though because that would probably be a region-dependent problem.

Edit: I just realized the poster said that it was Zorin OS 16.3:

and I'm using it right now... I have an Honor laptop though, not an HP computer so it can still be a driver issue.

1 Like

That would be nice to know what was changed, heh. I would double, triple, maybe even quadruple check for secure boot status. If there are any HD options in BIOS, take note of what you have - as was pointed out, there may be more than one disk with RAID.

Maybe hold off on the boot log for now, might not be needed. And if you did check it out already, just list what is shown with [error] status.

Is why I mentioned checking the SHA hash for the downloaded .iso and compare the value with what is on the Zorin site. But, yes, still a valid point. Doubtful it's corrupted on the server side though..

Yeah, the other post is a different issue I'm thinking.. specs on that says M.2 NAND flash for storage type but nothing else; and a possibility of more modules installed along with it but, not sure as of yet..

Definitely check the BIOS settings, maybe even reset BIOS to factory settings and disable secure boot, check the storage type if it's AHCI or RAID, then check again after a reboot - might have a dead CMOS battery, check the SHA hash of the downloaded .iso - check the USB drive being used for installation. Likely not an issue but, have had a USB just give out randomly.... cheap, cheap one though - but, worth checking.

That would be a good option as well before all the other stuff; good idea!


Yes! We made it. We did what the other post said and it worked. It's an issue with the new kernel after all. We just have to wait for an update for the bug to be patched.

Yes, I enter to the system and there appear a system update and I update the system and I enter normally and this is on screen

This is in the version with the bug

@Flexi , has the posted solution here helped you, as well?
In your case, reinstalling Zorin OS from the .iso, then setting your kernel to default boot to the Working Kernel:

This way you can safely install updates.


Awesome! Good to hear :grin:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.