Zorin core upgrade/reinstall booting to black screen

Hi, I have upgraded Zorin core 16.3 on my HP T630 and now when booting, I get a flash of desktop before it goes to black screen. I have tried a fresh install of 16.3 with the same effect. I have also tried to install 16.3 Lite with the same effect and have downloaded the images several times in case of corruption. If I boot from USB without installing, they work fine. This is not specific to one machine. I have 3 of these thin clients and it's the same on all but they've
all worked ok for over 12 months before the last software update. Any ideas please?

NOTE to Readers: Please follow some of the discussion following the marked solution in order to gain more insight on the trouble as well as how to lock in the kernel to prevent further issues.


Wait of my friends had this issue yesterday... It might be an issue with the download itself. He also has a flash and then the computer blanks out. Or, it is a problem with the update. I haven't gotten the update yet but I will probably wait because it might be a bug with the update

1 Like

Not very likely an update causing this - that sounds more like, kernel..

@Madrus Welcome! :smile:

When booting, do you get a Grub boot menu on the screen? If so - don't boot the first option, select Advanced options for Zorin in the list, then select the previously installed kernel, but not the (Recovery) option. If you are able to boot normally, that kernel needs to be 'locked into place', so to speak, so it won't be updated again causing the issues.

Here's an example (random pic from the archives):

Then select the second option in the list, then you'll get (another random pic, this time Ubuntu):

The 3.2.0-40-generic is the firs tboot option Grub will load by default - same as with Zorin. After getting to this menu, just select a lower version kernel than what's being loaded by default, then test - if that works, then your new kernel is the issue.

1 Like

Yup, it sure is! That's why I said, example :wink:


This actually raises even more questions.

If the OS was working until a recent upgrade (5.15.0-86) - then why would the same issue appear on the downloaded .iso which does not carry that upgrade (5.15.0-78)?

At first, I was thinking hardware. But then I read:

@Madrus , have you checked for any Firmware updates on the HP side?


My friend and I had the same issue... We tried it... And it worked. It's the kernel


Gday @Madrus
If this is a kernel update issue & if what @PlumpKibbles suggested doesn't work or your just having trouble.
Maybe an easy way is to use your usb stick ( that i assume is a good copy that you have kept & used before, & seems to work on "Live") try to install "Without" internet connection & see if you get the desktop appearing/system working.

As this has happened with other machine's of the same that you have, the reason maybe as @Aravisian suggested, update/check UEFI firmware/drivers on all machines.
Hope this helps.

If after updating the firmware, & you still have trouble using the latest kernel.
Then we can help you by holding the kernel.
If needed, someone will help with this.

1 Like

I didn't even think to mention I never install with inet attached.. good call! I've had more broken systems installing with inet than not!

1 Like

Thanks @PlumpKibbles it works with the older 5.15.0-84 kernel on all machines so it must be the newer 5.15.0-86 version. I'm a user, not a techie so all I need now is some assistance in locking the kernel in place.


I know how with vanilla Ubuntu, I'm not sure if there's a better option for going about this in Zorin - I'm sure I'll get tagged if not lol ..

I would use uname -r to get your current running kernel, then sudo apt-mark hold 5.15.0-84-generic. It should say a few packages are being held or set / marked as hold.

When there's a working update, you can just use sudo apt-mark unhold 5.15.0-84-generic to release the hold from updates - run apt update / upgrade, then it should upgrade to the latest kernel. I was doing that with some kernels in Mint for some devices that didn't play too well on 5.15 or 5.19 kernels..

As far as to see when these bugs / patches are released - I'm not exactly sure on that one..


On this other topic I made, for the problem with my friend, @Aravisian replied with this, when we figured out it was the Kernel:

"That way you can safely install updates", and change your kernel. Haven't had time to try it but probably works.

1 Like

Should be true with how I normally go about it - updates come through, just no kernel updates.

Was looking for that myself lol beat me to it!

1 Like

Yes, exactly.
Both methods can prevent the user from using a kernel that has a regression they are affected by.

The difference between them:
The apt-mark hold method will prevent the kernel from upgrading. To the user, the locked in kernel is the highest available to boot into.

The set-kernel-default method will allow the kernels to upgrade. The user default boots into the working kernel, even though higher kernels are installed.


I'll have to remember to use set-kernel-default next time; have not tried that method before.

1 Like

It was actually @Aravisian who found his own post and then shared it with my thread lol.

Oh I'll tell my friend (@Flexi) to try that.

Many thanks @PlumpKibbles @Aravisian @JoshOfCourse
I tried the version using grub on one machine, but I must have done something wrong as it didn't fix it. I used the apt-mark hold and all 3 are working fine again.

1 Like

I'm tempted to get one of these T630's :thinking: saw one on eBay for kinda cheap-ish lol I'm liking the SC fiber on the back :wink: Don't normally see that!

I have moved the solution marked to post#3
What we aim for is the first post that notes what to do to solve the issue, in order to allow users a shorter and faster read to find the solution.

This thread is a complex case, however, referencing another thread and multiple points made for what to do after rolling back the kernel.
To this end, I edited the O.P. to note readers may want to read the entirety of the thread in order to fully solve the issue.

1 Like

Gday @JoshOfCourse ,
Thank you for passing this result onto @Flexi , If @Flexi needs further help..
Please tell @Flexi "Don't hesitate to ask for help".

Zorin forum community.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.