Colors are very dark and saturated on Zorin 17.1

Hello ! Since I upgraded from Zorin os 17 to Zorin os 17.1, my colors are really weird: both dark and saturated. It's really disturbing, what can I do?

I've attached some screenshots, but I don't know if they'll be visible to you.

Capture d’écran du 2024-03-24 10-46-18
Capture d’écran du 2024-03-24 10-46-38

The screenshot looks fine to me, so it's probably not capturing the real issue. Can you run this on the Terminal?

sudo lshw -C video

Waht do You exactly mean with ''dark and saturated''?

The Taskbar looks white and transparent like it should. You could change the Transparency. Or try it with a lighter Background Picture.

It returns this (sorry this is in French) :

       description: VGA compatible controller
       produit: Intel Corporation
       fabricant: Intel Corporation
       identifiant matériel: 0
       information bus: pci@0000:03:00.0
       nom logique: /dev/fb0
       version: 08
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pciexpress msi pm vga_controller bus_master cap_list rom fb
       configuration : depth=32 driver=i915 latency=0 resolution=1920,1080
       ressources : irq:57 mémoire:fb000000-fbffffff mémoire:d0000000-dfffffff mémoire:fc000000-fc1fffff

I mean that the colors are modified. For example, the red color of the YouTube logo has become reddish-brown.

Hmm .. to be honest: I don't see that on Your Picture. for me it looks like normal red Youtube Logo.

Did You have activated the Night Light in the Display Settings? It makes in common a warmer Color. You can find it in Settings > Displays and there at the upper Edge beneath the Display Settings.

Or you could take a Look in the Color Settings and how they are adjusted.

1 Like

It looks normal in the screenshot to me, as well.

What this suggests is that the colors are being displayed incorrectly, but captured correctly by the screenshot tool- The information for the display is correct, so the point of failure is the graphics display.

The lshw command seems to be a bit vague. Let's try inxi

sudo apt install inxi

Then run

inxi -G

and relay the output here.

Which kernel are you on? (The Intel i915 driver is supplied by the kernel)

uname -r

Were any packages held back during the upgrade?

sudo apt update && sudo apt full-upgrade

I haven't activated the Night Light, but I can't adjust the Color in the Color settings...

The output is:

  Device-1: Intel driver: i915 v: kernel
  Display: x11 server: X.Org v: driver: X: loaded: modesetting
    unloaded: fbdev,vesa gpu: i915 resolution: 1920x1080
  OpenGL: renderer: Mesa Intel Arc A750 Graphics (DG2)
    v: 4.6 Mesa 24.0.2 - kisak-mesa PPA

Your command return :

I've tried to update but it change nothing

Arc - there we go.

The new Intel Arc graphics has limited support currently on GnuLinux.
It's spotty.
Have you tried rolling back to the earlier kernel?
From Boot, tap esc or tab key to pull up the Grub Menu if it does not appear with each boot.
From Grub Menu, select Advanced Options for Zorin
From the next menu, select Zorin on 6... - the earlier kernel that you had before upgrading to 6.56.0-25 to boot from.
Once logged in, check uname -r to ensure you are no longer on the 6.5.0-25 kernel, then look for the chromatic errors.

If still no good and you have no earlier kernels to try - you can try installing a later 6.7 kernel.

Ok, I'm gonna try

It changed nothing...

How many kernels and which do you have installed?

dpkg -l | grep linux-image

I pursue this because you said it was working on 17, but not 17.1

Otherwise, you can try installing the 6.7 or even 6.8 from the Mainline:

I think a lot :

rc  linux-image-6.2.0-39-generic                        6.2.0-39.40~22.04.1                          amd64        Signed kernel image generic
rc  linux-image-6.5.0-14-generic                        6.5.0-14.14~22.04.1                          amd64        Signed kernel image generic
rc  linux-image-6.5.0-15-generic                        6.5.0-15.15~22.04.1                          amd64        Signed kernel image generic
rc  linux-image-6.5.0-17-generic                        6.5.0-17.17~22.04.1                          amd64        Signed kernel image generic
rc  linux-image-6.5.0-18-generic                        6.5.0-18.18~22.04.1                          amd64        Signed kernel image generic
ii  linux-image-6.5.0-21-generic                        6.5.0-21.21~22.04.1                          amd64        Signed kernel image generic
ii  linux-image-6.5.0-25-generic                        6.5.0-25.25~22.04.1                          amd64        Signed kernel image generic
ii  linux-image-6.5.0-26-generic                        6.5.0-26.26~22.04.1                          amd64        Signed kernel image generic
ii  linux-image-generic-hwe-22.04                                      amd64        Generic Linux kernel image

I've also noticed that if I boot on a usb key with the safe graphic mode, I no longer have any problems.

Have you tested the 6.2 kernel, yet?

No, I'll try. But I don't know much about linux commands, what's the corresponding command?

No commands are needed, just follow the same procedure as before:

But it doesn't appear in the grub menu
I've only the 6.5.0-26 ; 6.5.0-25 ; 6.5.0-21


sudo apt install linux-image-6.2.0-39-generic linux-headers-6.2.0-39-generic linux-modules-6.2.0-39-generic linux-modules-extra-6.2.0-39-generic

Then reboot, enter grub menu and it should list the 6.2 option.

It didn't work...