Comodo Antivirus for Linux

I downloaded cav-linux_x64.deb from:

In trying to install it, Software Center error'd out - it couldn't install due to unmet dependencies. Software Center didn't detail which dependencies, however.

No problem:
sudo dpkg -I /home/$USER/Desktop/cav-linux_x64.deb

 new Debian package, version 2.0.
 size 25921630 bytes: control archive=10912 bytes.
     903 bytes,    19 lines      control              
   14471 bytes,   203 lines      md5sums              
    9396 bytes,   204 lines   *  postinst             #!/bin/bash
      49 bytes,     1 lines   *  postrm               #!/bin/bash
    6625 bytes,   220 lines   *  preinst              #!/bin/bash
   10037 bytes,   313 lines   *  prerm                #!/bin/bash
     181 bytes,     8 lines      shlibs               
 Package: cav-linux
 Version: 1.1.268025-1
 Architecture: amd64
 Maintainer: comodo <>
 Installed-Size: 73597
 Depends: libc6 (>= 2.4), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.12.0), libice6 (>= 1:1.0.0), libpam0g (>=, libsm6, libssl0.9.8 (>= 0.9.8m-1), libstdc++6 (>= 4.1.1), libx11-6, libxext6, libxrender1, zlib1g (>= 1:1.1.4)
 Section: alien
 Priority: extra
 Description: COMODO Antivirus and Mail Gateway for Linux
  COMODO Antivirus and Mail Gateway for Linux.
  COMODO Antivirus provides real-time protection for file system.
  COMODO Mail Gateway brings inbound and outbound email security with real-time antivirus function.
  After installation:
  Please run /opt/COMODO/ script manually to configure it.
  Please start COMODO from Menu or Desktop.
  (Converted from a rpm package by alien version 8.86.)

libc6 (>= 2.4)
libc6/focal-updates,now 2.31-0ubuntu9.9 amd64 [installed]
GNU C Library: Shared libraries

libfontconfig1 (>= 2.8.0)
libfontconfig1/focal,now 2.13.1-2ubuntu3 amd64 [installed,automatic]
generic font configuration library - runtime

libfreetype6 (>= 2.2.1)
libfreetype6/focal-updates,focal-security,now 2.10.1-2ubuntu0.2 amd64 [installed,automatic]
FreeType 2 font engine, shared library files

libgcc1 (>= 1:4.1.1)
libgcc1/focal-updates,focal-security,now 1:10.3.0-1ubuntu1~20.04 amd64 [installed]
GCC support library (dependency package)

libglib2.0-0 (>= 2.12.0)
libglib2.0-0/focal-updates,now 2.64.6-1~ubuntu20.04.4 amd64 [installed]
GLib library of C routines

libice6 (>= 1:1.0.0)
libice6/focal,now 2:1.0.10-0ubuntu1 amd64 [installed,automatic]
X11 Inter-Client Exchange library

libpam0g (>=
libpam0g/focal-updates,focal-security,now 1.3.1-5ubuntu4.6 amd64 [installed]
Pluggable Authentication Modules library

libsm6/focal,now 2:1.2.3-1 amd64 [installed,automatic]
X11 Session Management library

libssl0.9.8 (>= 0.9.8m-1)
sudo apt search libssl0.9.8
Sorting... Done
Full Text Search... Done
libssl1.1/focal-updates,focal-security,now 1.1.1f-1ubuntu2.17 amd64 [installed]
Secure Sockets Layer toolkit - shared libraries

libstdc++6 (>= 4.1.1)
libstdc++6/focal-updates,focal-security,now 10.3.0-1ubuntu1~20.04 amd64 [installed]
GNU Standard C++ Library v3

libx11-6/focal-updates,focal-security,now 2:1.6.9-2ubuntu1.2 amd64 [installed,automatic]
X11 client-side library

libxext6/focal,now 2:1.3.4-0ubuntu1 amd64 [installed,automatic]
X11 miscellaneous extension library

libxrender1/focal,now 1:0.9.10-1 amd64 [installed,automatic]
X Rendering Extension client library

zlib1g (>= 1:1.1.4)
zlib1g/focal-updates,focal-security,now 1:1.2.11.dfsg-2ubuntu1.5 amd64 [installed]
compression library - runtime

Is it worth it to install it, knowing the dependencies?

Is libssl0.9.8 the only thing that's lacking above? If so, can we create a sym-link named libssl0.9.8, and link it to libssl1.1?


Sorry, we were unable to deliver your message to the following address.


No mx record found for

Looks like no one is maintaining that package.

Seems to be a converted rpm package which why it may making crunch in the machine room, better check the dependencies of the rpm file then. LAzyness I guess not making a real .deb package.

1 Like

Don't Bother, the last release for .db was 2013, some users have tried to strecth it out, but there's no developer support, its looking for older versions of libssl1.x that are no longer supported or in repos.

I don't really care that the software itself isn't updated regularly... if it works the way it's supposed to, it doesn't need an update.

What I care about is if it's downloading recent virus signature database files.

There's a way we can get the install working!

Extracted deb-package and edited DEBIAN/control file to add the missing dependency for “libssl1.0.0”

dpkg-deb -R cav-linux_1.0.220659-32_amd64.deb cav-linux_1.0.220659-32_amd64/
nano cav-linux_1.0.220659-32_amd64/DEBIAN/control
dpkg-deb -b cav-linux_1.0.220659-32_amd64/ cav-linux_1.0.220659-32_amd64_libssl1.0.0.deb

This has been patched in line “Depends:”

-- libssl0.9.8 (>= 0.9.8m-1) ++ libssl0.9.8 (>= 0.9.8m-1) | libssl1.0.0

After repack install and it seems to work so far!

It's still missing redirfs and avflt modules, though. :expressionless:

An update on what I've found thus far:

How Install...
(1)Execute CAVL installer.
(2)Download driver.tar from
(3)Replace /opt/COMODO/driver.tar

When "Check for Updates" is executed, update driver.tar again before reboot.

That URL, though, is 404. :expressionless:

The problem though at least as I understand it, is that it relies on the 2013 libssl1 libraries, the libraries have been updated too drastically since then and thus doesn't run even when you have the library installed, and rolling back and installing an older version may break much more. as this handles ssl - so could potentially break all internet traffic for you install.

Kinda like how an application will run on Java 1.6.2_100 but not 1.6.2_101 until the developers update the jar file to a new scheme or call name.

The other concern here is that all updates to the package are cve related security vulnerabilities, so using an older version will open your system to known exploits in the wild and as amazing as Linux is its still not a good idea. Which indicate that its failure to work on modern versions may lie in it use of outdated unsafe and broken ssl

1 Like

Hi all.

Why not use ClamTK - I see it is still active and on-demand scanner.

Correct me if I am wrong, this isn't Windows so AV isn't really needed For Linux 'per say' and having an on-demand AV for USB Drive scanning etc I would recommend.

I know the above is debatable so please don't hate :slight_smile: - just commenting on my current experience and what I currently do with Linux and AV protection.

If anyone has better recommendations, I will also appreciate it. :slight_smile:

Cheers and greetings from South Africa.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.