Compiz and compositor manager change full

I am running zorin 15.3 core xfce4
I install compiz
and create in configuration -> session and start
a autoload entry to run compiz
it work but...
really the pc load first xfwm4 and later replace it for compiz (slow start and waste resourse and time, and also a ugly glitch)
I want to start compiz directly from the beguining and dont use the autoload entry

"my?" zorin 15.3 core xfce use ligthdm
and i am stuck here, i am a novel user, can you help me please

the best for me is load compiz directly from ligthdm in default session instead of xfwm4

You can use the command bash -c "sleep 2; compiz --replace" in the Autostart Applications.

Copy and paste this to a text editor file


sleep 2 && compiz --replace;

Save it anywhere is convenient... Documents folder for example.
Create an autostart entry:

Hello good day
this does not solve the problem, compiz is already running at startup,
what I want is that it does not load the xfwm4 composer at any time.
The default session first loads xfwm4 and then executes the startup entries, it can be seen at startup as loading xfwm4 and then changes to compiz and in the change, the desktop graphic elements blink like a glitch
what I want is to change where the composer loads the first time, and tell it that instead of starting xfwm4, change that value to start compiz, so it would not have to use entries in the start menu
please help

I see... I am not sure how stable Compiz is these days, so let's get risky.
In terminal run

sudo nano /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml

Scroll down to this line:

<value type="string" value="xfwm4"/>

Change to:

<value type="string" value="compiz"/>

Hit ctrl+x to exit, hit the y key to say 'yes', then the enter key to save as current configuration.
The terminal will revert to normal.
You can reboot or log out and in to see the changes or test.

first OK thanks!!!
that's exactly what I wanted!
but when opening the file
he was already like this

i guess it autoconfigured when compiz runs
If I deactivate the access created in the start menu, when starting it runs xfcevm4 no compiz and the configurations of that file if saved
so where does xfcevm4 start?

if I runs
or through configuration management -> configuration editor

but I can't edit because the button is disabled

but if I run
sudo xfce4-setting-editor

then compiz appears as the default composer
Besides that the edit button is also disabled...
I change the account type to an "administrator"
but even so, compiz does not run
I don't know why that happens
thanks or your time and patience


Have you installed CCSM?

sudo apt install ccsm

rm ~/.cache/sessions/*

Run ccsm, then;
Check to 'on' for Effects > “Window Decoration” and Window Management > “Resize Window”, “Move Window”.

Ensure that XFWM4 is removed from Sessions & Startup > Autostart

EDIT: perhaps we are missing steps. I do not like video tutorials, so have not watched this- but perhaps you are more tolerant than I am:

1 Like

ok i did that
edit the xfce4-session.xml file
and change the value to compiz

additional to this I also ran this command

xfconf-query -c xfce4-session -p /sessions/Failsafe/Client0_Command -n -a -t string -s "compiz"

I read it in the following link

link here

deactivate the entry that I had made for compiz in the start menu and when restarting the session it already starts compiz by default

curiously in the tutorial they advise not to use compiz LOL

Thank you very much, I have solved the issue

1 Like