Completely disable Tracker

My fans have been running non-stop on my laptop since I reinstalled Zorin OS 16 Pro. The problem has to do with tracker.

I've tried

systemctl mask [all_tracker_services]
tracker reset --hard
reboot

And, it didn't work, the fans just continue to spin harder since tracker seems to start indexing from scratch.

I've tried adding

Hidden=true

To

/etc/xdg/autostart/tracker*.desktop

Still, tracker continues to index and make my fans run at max speed. This is highly annoying. Please, does anybody know of a way to disable tracker completely? I really do not want to install Windows again just because of some fan problem due to this horrible software

@guinness1 , what steps did you take to confirm that tracker is the cause of the hyperactive fans?

Check your BIOS, verify that the fans are not in some kind Performance mode.

1 Like

htop, system resources and I found a way to kill the current tracker process:

tracker daemon -t

This immediately stopped the 100% fan use. If I reboot, I have to rerun that to stop tracker from spinning up the fans and thrashing my SSD/NVMe.

@rumplin - It's only GNOME-based distros that have this problem; and, the problem goes away if I manually run the above command.

2 Likes

I just needed to be sure it had been verified in order to avoid the X- Y problem. :wink:
If this was me, I would probably use the mask command.

This guide may have more helpful tips:

@Aravisian Thank you for the reply, but that does not work. In fact, following those instructions made the problem worse because tracker would reindex

I've tried to wait it out, but the fans ran for over 1 hour before I found that command I put earlier

I have noticed that the gnome-tracker is uhh... stubbornly resistant to being shut down. That above guide notes the same.

This is from an early article on early edition of Ubuntu, so not sure if it would help or harm:

"Comments and Discussion

How to disable tracker globally :

Disabling tracker for globally (for all users)
    Edit /etc/xdg/autostart/trackerd.desktop file with root priviledges (sudo vim, gksudo gedit ...)
    Add "Hidden=true" to the end of the file
    Do the same for /etc/xdg/autostart/tracker-applet.desktop if you want 
Disabling tracker for your user only
    Enter the directory "~/.config/autostart", create it if it does not exist
    Create a file named trackerd.desktop
    Paste the following into the file, save and exit 

  [Desktop Entry]
  Encoding=UTF-8
  Name=Tracker
  Hidden=true
  • Gokdeniz Karadag"

[Source: Tracker - Ubuntu Wiki]

Thank you, but that's one of the first things I tried; I tried it globally and per user.

If I shutdown or reboot, tracker comes on with a vengeance, like it's punishing my audacity to want to turn it off

1 Like