Computer keeps going into a boot loop on start up

Having issues with my Zorin install seemingly not playing nice with my graphics card. It seems to throw a boot loop when I attempt to boot it off the drive where the second monitor turns on. It looks promising before seeming to halt, catch fire, and reboot. I'm rather at a loss on what could be going on as I'm unable to find any other drivers that can alleviate the issue. See the video here for the behavior of the issue.

When I have been able to boot into Zorin, it's been in a safe/recovery mode where it's only detecting the Display Port monitor. Obviously would like the full experience with the computer and to use the second monitor.

Just to cover bases, a hardware issue has been ruled out, both monitors work fine in Windows 10 and the Zorin boot loader doesn't have any issues with displaying so I'm going to assume that it's something in the initial driver load that's failing. I don't know otherwise though why it's having this issue though, it had this issue with the install USB where a second option booted up fine but the first sent it into a loop. Also, the system has been updated to the latest version with the built-in updater as far as I can tell.

Just to let anyone be willing to help with my technical issue. Be warned that I'm no programmer or computer scientist but I am comfortable doing whatever I'm being pointed at, be it in the terminal or rooting around in the bowels of the Zorin kernel armed with the proper commands and steps.

Computer specs:

CPU: Ryzen 5 3600
Motherboard: MSI B450 Tomahawk MAX
RAM: 32GB DDR4 3200 Gskill
Video Card: MSI Radeon R9 390 GAMING 8G

Hope this helps. Let me know if there are any further things I can send or provide to help.

UPDATE:

I unplugged the second monitor and disabled the MSI SpeedBoost overclock. Farthest I got was the Zorin Splash screen under normal operating mode before crashing and/or restarting/ and or freezing. Safe/Recovery mode boots fine still. At a loss still, will investigate this more later.

This is definitely the thing to troubleshoot.

Have you tried the Oibaf drivers yet?

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

AMD puts up a front of being supportive of Open Source while simultaneously withholding crucial driver information. It's just... the way it is.
What you can try is a series of Grub parameters to try to force the graphics to play nicely:

sudo nano /etc/default/grub

On the line for GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" change it to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet radeon.cik_support=0 radeon.si_support=0 amdgpu.cik_support=1 amdgpu.si_support=1"

ctrl+x to exit, then press the y key to say yes to save, then the enter key to save as current configuration.
The terminal will revert to normal.
Now run

sudo update-grub

To secure the changes to grub file into the system boot.

1 Like

Make sure you have SECURE BOOT disabled :wink:


2 Likes

Just wanted to say that this has worked perfectly. I've restarted the computer several times and it seems to be booting perfectly. Thanks so much.

Could I add the SPLASH command to the Grub system to get the splash screen back? Experimented and got it back just adding Splash to the grub command. Thanks once again!

Thanks once again!

2 Likes