Conky not showing transparent background

Is this essentially a Default Install of Zorin OS, or have you ever installed (even if you alter removed) other Desktop Environments, gnome extensions, plugins etc?

No other Desktop enviroments, but I have installed and uninstalled plugins for gnome.Things like plank, dash to dock,etc...
Maybe there are packages missing?

Have you tried

sudo apt install -reinstall conky-all

No I have not, but I haven't installed nothing new since Conky, so I don't see how can be that something is missing on the conky install.

If files were incomplete due to packet drop during transfer, it could happen. I would try reinstalling the conky-all package, just in case.

Just a friendly FYI:

Even the tomtomtom ppa of Conky Mananger doesn't work properly. It does not recognize new conky code. Widgets with new code are invisible to it. I've tested on both Zorin and Pop OS.

Best to only recommend conky-manager2

Just so you know, I too am having issues with transparency in Conky with Gnome x11. After days of testing, I believe the issue is with x11, not conky. Seems x11 has difficulty with the own_window_argb values.

I am currently looking into replacing x11 with a different composite manager. If it is possible and it works, I'll report back here for you with the fix.

Edited above post to be for CM2.
I have had no trouble with it all this time, so I was curious and looked into it.
I discovered I have had no trouble because I am using Conky Manager 2 already...

And that also solves the mystery about the differences between the two.

I have no trouble with X11 using Cinnamon, Mate, XFCE or Plasma.

The only viable alternative to the X window system is Wayland and we all know how well that is going...
And it appears the problem is more Gnome side (Desktop Management) than it is X Window, since only Gnome seems to be affected.

Yes, it's definitely on gnome's end because the issue occurs on both Zorin and Pop gnome.

If argb values are in the config file (even if set to false) I am unable to display black text or black .png files and the background transparency will only display in black.

The only way to get the background to change color and to display black text and png's is to comment out the argb values completely.

The argb values also interfere with own_window_type . Using "override" crashes widgets completely. If argb is enabled then the only option is "normal". Only if argb values are commented out am I able to display own_window as "desktop".

I'm am hoping there is a way to fix this in Zorin.... And ideas?

I never got conky transparency work on proper on Gnome.

I actually have fudged with it enough that I have transparency working now. If you want to try it I'll gladly share my config with you.

Last hurdle is that it still refuses to display black .png files. Any other color is a go... just not black. Like... what the...?

1 Like

Sure. Then I can tinkering with it. I don't have conky on my main computer at the moment, but I can just install it there :stuck_out_tongue:

2 Likes

Any help you offer, especially in this thread is Golden and Welcome.

Since I do not use Gnome, I appear under-qualified for the topic.

I had trouble with Conky Transparency on Zorin OS LIte until I figured out to enable a setting in the Window Manager Tweaks... and it was as easy as that.

EDIT:
Thinking about XFCE in combination with @Tink 's comment about the X Window system made me wonder...
It's the setting to enable Compositor in XFCE that allows Transparency for conky (and other things).
Cinnamon includes that enabled by default (Marco, I think). So does KDE.
LXDE and LXDE-gtk3 both do... I think Mate does have it enabled (Compton, I think), but I'd have to look.
Just as all the Desktop Environments contain their own compositor - So Does Gnome.
Gnome uses a fork of Mutter called "Clutter".

Using Compiz on Gnome May be a simple way of solving the issue...

@Valkyria @Storm

The fix I have found for conky transparency is this:
own_window = true,
own_window_transparent = 'true',
own_window_type = 'Conky',
own_window_argb_visual = 'true',
own_window_class = 'override',

Read carefully, as I missed how this was any different .... until today. Nearly all of the conkys I've seen have:

own_window_type = 'normal', not own_window_type = 'conky,

Also, adding own_window_class and using that for 'override', seems to be the key vs using own_window_type = 'override',

The only drawback with this config is that semi-transparency (adjusting the own_window_argb_value) has no effect.

But still, it works... and that's something!

2 Likes

Awe shucks, thanks for that. Makes a girl feel welcome.

Clearly not true as your suggestion on Compiz is golden, my friend.

Am installing it today in a VM to test drive it and also use it to test all these conkys I've written.

I installed a gnome ext called "glassy Gnome" thinking it may provide what I needed, but it was a no-go.

I am going to give Compiz a go in hopes of fixing the issue of black/dark png's not displaying.

Is this a straight-forward install, as in it compliments my current setup or are there any conflicts I need to be aware of before hand?

It has been a while since I installed Compiz. It generally is straight forward... you may need to also install a ccsm manager for it.
I had to look that up real quick... simple-ccsm compiz-fusion-plugins-extra
So...

sudo apt install compiz simple-ccsm compiz-fusion-plugins-extra

Once installed, Compiz must be configured. This is done by launching CCSM and going through the settings. I do not recall offhand - but there was some detail that had to be checked on and another that has to be checked to off... I will try looking that up when I have time.

No, no. This is more than enough help. Thanks so much for this. I'll look it up. If something goes awry I'll come back.

1 Like

Thank you for this, unfortunately it does not work on my side. If you try to install Compiz, please tell us how it goes. I believe that the source of the problem it's in there.

I forgot to mention, when doing the above settings for transparency, also comment out own_window_colour

--own_window_colour

Once window color is removed, it works.

1 Like

Here is a link to another post on Conky transparency with a sample conkyrc to use. This hopefully will solve your issue... finger's crossed.

1 Like