Conky start delay & kdiskmark possible permissions fault

Two problems see above title.
First conky.
I had my conky working fine, one of the things it does is display the IP address, but since I changed my /home drive (it's on a different drive to / (root) from a HDD to a SSD, the conky starts before the internet is on line and so I don't get the IP address, until it refreshes which I set to 30 minutes. I saw in another post that Aravisian has delayed conky start by 20 seconds, so I wondered if you could advise how you done this?

Second, I have installed kdiskmark from a deb as I don't choose to use flatpack after all the hassle I had getting onlykey app to work, in the end I got a deb for that as well, no problem with the deb installs. OK moan over now! back to kdiskmark, when i run the test on /home (sdb1) or on /media/chris/music (sdd1) or on /media/chris/original_home (sdc1) it works fine runs and gives results, but when I try to run the test on / (sda1) I get an error message "an error has occurred while creating the benchmark" file". To me this seems to be a permissions issue, is there anyway that I can change the permissions granted to this app? As I suspect that would solve the issue.
All help gratefully received.

Sure thing. Save the following file as conky-startup.sh in your ~/.conky` directory. You can copy/ paste the below into that saved file (NOTE: Zorin Core users would use "zorin-os-desktop" session instead of Lite):

#!/bin/sh

if [ "$DESKTOP_SESSION" = "zorin-os-lite" ]; then 
   sleep 20s
   killall conky
   cd "$HOME/.conky"
   conky -c "$HOME/.conky/conkyrc"
   exit 0
fi

You may want to modify the above to include other conky objects to startup or to have it point to a different location.
But there is an easier way than scripting it.
Install Conky Manager:

sudo add-apt-repository ppa:tomtomtom/conky-manager

sudo apt update && sudo apt install conky-manager

Launch CM (Conky Manager) and click Settings
Under general, click Run conky at startup
Then click `Startup Delay (Seconds) and set your delay. This will create the above script for you.

Which drive is Root installed on?

2 Likes

Thanks for the script for conky, I did install conky manager 2, as per your instructions as it goes from another post! but I don't use it, so will likely remove it at some point. I'll create/ copy your script, that's easier for me I think.

Root is on sda2.
Kdisk does show root (/) correctly as the drive space capacity is correct for root and this is the one that I get the error on.
Kdisk does also show /boot/eft (sda1) but this is only 0.5GB partition so I have never tried to run the test on it, also it's FAT 32.

1 Like

This should be /boot/efi, which is normal at 500MB.

EFI partitions are normally FAT32.

I have never used kdiskmark. But with Gnome-Disks, the write benchmark function cannot work on Mounted or System drives. Kdiskmark may be the same in this regard.

It clearly is working on the other partitions and drives; so we can disregard other possible errors.

Sorry that was what used to be called the "sausage fingers typing", I did mean /boot/efi, I just mis-typed it!

I never thought of that, it could be the case I will investigate some more and come back to you on this.

1 Like

I have done some more investigating now, I come across this site

In the text was this “If you have multiple drives connected, choose the appropriate empty directory in each storage device. The bottom row will show the currently selected storage drive.”

The above of which is clearly wrong anyway because the directories are not empty but it made me think more, so what I decided to try was not to do the test on the “root” directory but on another directory which is still on the same SSD (sda2) as it goes I then decided to use the “/mount” directory.
which is on the same SSD (sda2) and this worked, so I am still getting the data for the correct SSD (sda2),

I do believe this is a permissions issue still, because using “/mount” means I am still testing the active drive, so it’s not the fact that it is the system drive but that Kdiskmark is wanting to create the benchmark file. on “root” still I can do it with other directories on the system disk, so that’s solved it as far as I am concerned.

From what you said about Gnome-Disks, Kdiskmark would appear to be the opposite, in that the disks have to be mounted before they can be tested and it will test alive system disk

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.