Context menus in Ultimate version?

I am very new to Zorin and I got it installed on my laptop, but have noticed zero context menus. I thought I installed the Ultimate version, but have started to wonder if it is the core version and if so, I am in hopes that I can upgrade to the Ultimate version if it includes context menus as well.

Can someone answer my question.. Thanks!

Could you post a screenshot of what you are seeing?

There are very little differences between Ultimate and Core as far as UI and such. Ultimate comes with many apps pre-installed as well as a macOS appearance option - but, Ultimate does not "unlock" features or come with "the rest of the operating system at a price."

Choosing Ultimate is a way to Support development- it is a want not a need.

Hello and welcome to the forum.

Ultimate version is a paid version.
If you did not purchased it, it is either Lite, Core or Education version.

I really do not understand what you mean by context menu.

Essentially Ultimate version is the same as Core version with pre-installed games and Mac like desktop theme. People purchase Ultimate version in lieu of supporting Zorin developers.

Thank you for your response.
A context menu is just an additional menu when you right click on something.
I was trying to copy and paste (or save) an image in Firefox, and couldn't perform the action I had been used to doing in other OS's, and thus the reason for my query.

Thanks again!

1 Like

Ah ok. You can also call that popup menu.

Which should be present and working. I have never come across this issue before... Which Zorin OS version did you install?
Zorin 15.3? Or Zorin 16 Beta?
Lite, Core, Education (Lite or Core) or... Ultimate?
For release info- In terminal, please enter:

lsb_release -a

Thank you Aravisian for following up:

Zorin OS 15.3 (bionic)
'No LSB modules are available.'
(not sure what that means)

This is normal. The -a signifies to show all, so when it was unable to show lsb modules, it threw that notice.

Zorin OS 15.3 (bionic) This is going to be Gnome Desktop.

Are you using a Mouse or a Notebook Touchpad?

Are all popup menus failing to open or only certain ones?

I got the same thing, it seems normal.
(I am runnig 16 beta).

Notebook touchpad at the moment.

All popup menus that I can see at this point, but not have checked extensively.

You guys are awesome!

I think you should check the settings for touchpad.

This is how mine looks like:

(in Japanese, but English menu is in the same order)

1 Like

Can you press alt+F2 to pull up the launcher and enter into it
r then hit enter.
That is it. Just the letter r. This restarts the gnome-shell.
Try right clicking for Menu - if no-go...
Open a terminal and enter in:
nautilus -q
Then while still in terminal, launch nautilus from terminal with nautilus and watch for any errors.
with that running, right click around and see if you get any popup menus.

Was thinking this too. It could well be the Touchpad:

I am running Zorin OS on a different system, but I got a couple are warnings:

  1. sys:1: PyGIWarning: Nautilus was imported without specifying a version first. Use gi. requrie_version('Nautilus', '3.0') before import to ensure the the right version gets loaded.
  2. Nautilus-Share-Message: 11:55:08:380: Called "net usershare info" but it failed: Failed to execute child process "net" (no such file or directory)

I think you can also compare your touchpad settings with mine. (screen shot above). You can copy the setting if you want to try.


These are normal and unrelated to the issue.
I get that net usershare info on mine as well because the python script has a discrepancy.

Opening Nautilus (Which runs from Root) from your non-root user directory will throw this warning. It is harmless.

So... Touchpad settings is next?

Okay.. I tried to duplicate FrenchPress's settings, but it seems the layout is a little different than mine. Still not working for me.. :frowning:

Can you post a screen shot?

I will login with other system to try posting screenshot..

Also, did you read the link I posted? Does it help?

I do not use either touchpad or Gnome Desktop and I need to go run around the city... So I will leave this in Frenchpresses capable hands for now.

I pulled it up, but have not had a chance to follow through it yet with all that is going on here.. :blush:

Will try now.

Okay! That seems to work.. Thank you both for your willingness to be so helpful.
I sincerely appreciate it (really, really) :smiley: