Core 17.1 - seems slow to repond to actions and app startups on my Lenovo G780

For example, I click on something and the response isn't always immediate.


Pentium 2020M CPU @ 2.4GHz x 2
Mesa Intel HD Graphics2500 (IVB GT1)

This laptop used to run Windows 8.1 and worked pretty well so I'm surprised that Zorin is slower.

Even starting an app is very slow the first time it's fired up and I notice that the SSD is being accessed a lot even though I've only installed the OS, this primarily within the first few minutes after logging in.

I haven't tried Lite but surely this laptop should be able to run Core pretty well?

Did You tried it in Wayland and X11 Mode?

No, what is Wayland and X11 Mode ?

That are the Window Managers. Open the Settings Menu and go to the last Menu Point Info. There can You find the Info what You run:

The whole Xorg/X11 Wayland Situation is ... complex. X was first and exists much longer that Wayland. And Wayland can sometimes be a bit problematic. To test if this is in Your Situation the Case You should try to change the Mode.

That You can do on the Login Screen. There You click on Your User Profile so that the Password Field appears. It is important that it is appeared! When it is You should see in the bottom right Corner a Gear Symbol. Click on it and choose Zorin Desktop on Xorg and then You can log in and test if Your System runs better.

1 Like

Thanks, I'll take a look into that.