Corsair Hydro 110i - OpenCorsairLink can't find the fans

Good morning,
I have installed ZorinOS and am testing some of its impressive features.
I have a Corsair Hydro 110i
I tried with OpenCorsairLink to set the speed of the fans, but it tells me it can't find the fans, so I can't set them and they always stay at 100% power.

On windows with Asus AI suite application, I can drive them.

Can you guys help me?
Thanks

lorenzoeffe@lorenzoeffe-System-Product-Name:~$
$ sudo snap connect opencorsairlink:raw-usb
$: comando non trovato
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ sudo snap connect opencorsairlink:hardware-observe
[sudo] password di lorenzoeffe:
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ sudo snap connect opencorsairlink:raw-usb
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ sudo opencorsairlink --device 1 --fan channel=1,mode=6,temps=0:35:45:50:55:60,speeds=0:0:55:60:75:100
Dev=0, CorsairLink Device Found: H110i!
Dev=1, CorsairLink Device Found: HX750i!

Vendor: CORSAIR
Product: HX750i
Firmware: NA
Temperature 0: 37.87 C
Temperature 1: 29.68 C
Powered: 58852678 (681d. 3h)
Uptime: 21478 (0d. 5h)
Supply Voltage: 230.00 V
Total Watts: 84.00 W
Output 12v:
Voltage 12.09 V
Amps 4.50 A
Watts 52.00 W
Output 5v:
Voltage 5.00 V
Amps 3.50 A
Watts 17.00 W
Output 3.3v:
Voltage 3.34 V
Amps 2.00 A
Watts 7.00 W
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ sudo opencorsairlink --device 0 --pump mode=5
Dev=0, CorsairLink Device Found: H110i!
Dev=1, CorsairLink Device Found: HX750i!

Vendor: Corsair
Product: H110i
Firmware: 2.0.0
Temperature 0: 27.59 C
Fan 0: Not connected or failed
Current/Max Speed 0/0 RPM
Fan 1: Not connected or failed
Current/Max Speed 0/0 RPM
Pump: Mode 0x85
Current/Max Speed 2356/3000 RPM
Setting pump to mode: 5
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ sudo snap connect opencorsairlink:raw-usb
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ sudo snap connect opencorsairlink:hardware-observe
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ sudo opencorsairlink --device 0 --pump mode=5
Dev=0, CorsairLink Device Found: H110i!
Dev=1, CorsairLink Device Found: HX750i!

Vendor: Corsair
Product: H110i
Firmware: 2.0.0
Temperature 0: 27.61 C
Fan 0: Not connected or failed
Current/Max Speed 0/0 RPM
Fan 1: Not connected or failed
Current/Max Speed 0/0 RPM
Pump: Mode 0x87
Current/Max Speed 2360/3000 RPM
Setting pump to mode: 5
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ sudo opencorsairlink --device 3 --pump mode=5
Dev=0, CorsairLink Device Found: H110i!
Dev=1, CorsairLink Device Found: HX750i!

Detected 2 device(s), submitted device 3 is out of range
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ sudo opencorsairlink --device 0 --fan=3 --pump mode=5
Unknown suboption `3'
Dev=0, CorsairLink Device Found: H110i!
Dev=1, CorsairLink Device Found: HX750i!

Vendor: Corsair
Product: H110i
Firmware: 2.0.0
Temperature 0: 27.41 C
Fan 0: Not connected or failed
Current/Max Speed 0/0 RPM
Fan 1: Not connected or failed
Current/Max Speed 0/0 RPM
Pump: Mode 0x87
Current/Max Speed 2358/3000 RPM
Unsupported Fan Mode
Setting pump to mode: 5
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ sudo opencorsairlink --device 1 --fan channel=1,mode=6,temps=0:35:45:50:55:60,speeds=0:0:55:60:75:100
Dev=0, CorsairLink Device Found: H110i!
Dev=1, CorsairLink Device Found: HX750i!

Vendor: CORSAIR
Product: HX750i
Firmware: NA
Temperature 0: 37.62 C
Temperature 1: 29.94 C
Powered: 58853181 (681d. 4h)
Uptime: 21981 (0d. 6h)
Supply Voltage: 230.00 V
Total Watts: 64.00 W
Output 12v:
Voltage 12.09 V
Amps 4.00 A
Watts 44.00 W
Output 5v:
Voltage 4.97 V
Amps 3.12 A
Watts 16.00 W
Output 3.3v:
Voltage 3.34 V
Amps 2.00 A
Watts 6.00 W
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ liquidctl --match hydro set fan speed 0 0 100 0 45 55 50 60 55 75 60 100
PermissionError: [Errno 13] Permission denied: '/sys/bus/i2c/devices'
lorenzoeffe@lorenzoeffe-System-Product-Name:~$ liquidctl list
PermissionError: [Errno 13] Permission denied: '/sys/bus/i2c/devices'
lorenzoeffe@lorenzoeffe-System-Product-Name:~$