Creating Dual Boot with Windows 7 AFTER Install. GPT Drive and UEFI

Before I get started a little feedback on the ZorinOS install... You need a way to either choose a custom installation location with the "Alongside OS" option, or you need a checkmark or dropdown box in the Advanced/Something Else option so that ZorinOS is able to create the desired dual-boot behavior.

I have my drives partitioned the way I want, and I wanted to install Zorin to a comfy 50gig formerly Windows 10 partition. But the Alongside OS option, EVERY TIME, picked a main drive it wanted to install Zorin at the end of. NOT user friendly or desirable if the drive Zorin wants to install to has 2TB of stuff it has to move around! NO OTHER OPTION WAS GIVEN.

To get what I wanted I had to stumble through the Something Else option, and in doing so lost the ability to have grub take over. Now I have to select the boot device every time to get the ZorinOS option. The Grub menu is fine, and has Windows added. I would just want to increase the timeout to 30 and move Windows to the default. I have NO IDEA how to do that.

I have installed Grub Customizer, but am leery of using it as one article I found said it creates some issues. But that is a separate issue and not the focus of this thread.

This thread is concerning itself with making Grub the default bootloader from within Linux.I have tried the Windows Admin level Command Prompt commands - doesn't work. EasyBCD doesn't work with UEFI. Easy UEFI does nothing. I have done the commands in Linux, and things are fine there. Grub is perfect as it is even without my preferences. But my system refuses to load Grub - just boots into Windows.

As a last resort I might just move or rename the Windows bootloader, and see what happens. But before I go scorched earth on this, I would like to know any other options. Options that DO NOT REQUIRE ME TO REINSTALL ANY OS! If you point me to yet another install the OSes in this order tutorial I shall reach out of this screen and slap you!

This thread is directed to anyone fighting with getting the Grub bootloader to become primary after the install of some version of Windows and Linux, where their system just boots into Windows, but Grub is setup correctly.

Appreciate the help!

If you like, we can separate This Issue out to a new thread, so you can focus on your primary goal in this thread.

I am also wary of Grub Customizer. It's not a bad application but... There are just some things you want full control over.
To help you with the Timeout:
Let's look at accessing your Grub File- in two different easy ways.
The first- or familiar:

GUI method.

Open terminal and enter:

sudo -i



Now your File manager should open in Elevated Privileges.
Click "Other locations" from the Left Side pane. Now, select Computer.
Double click - /etc then /default then the grub file. It will open in a Text editor.

Second Method:

Open terminal and enter:

sudo nano /etc/default/grub

What to do:

A hashtag means that line is commented out and ignored by the system. Removing a hashtag uncomments the line, making the system honor its contents.
What you are looking for looks like this:
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian

You can see GRUB_TIMEOUT. Mine is set to 10 seconds. You can change that to 30.

Save the file if using Method One.
If using nano in the terminal, hit ctrl+x to exit, then the y key to say yes to save, then the enter key to save as current configuration.

Whenever you change grub, you must update grub for the changes to take effect:

sudo update-grub

Hope this helps.

OK, have the timeout. Also when updating Grub it said it added some stuff. But I have no idea what number Windows is. I wish I could see a list of boot items that I could organize to my heart's content!

Again, thank you!

Paste the following into terminal:

awk -F' '/menuentry / {print $2}' /boot/grub/grub.cfg

Doesn't work - just get a cursor prompt.

Ok... the Discourse forum software is doing things...

awk -F\' '/menuentry / {print $2}' /boot/grub/grub.cfg

Ok, got it. Had to parse it in just the right way for Discourse to show all of it. The above will work.

1 Like

Thank you.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.