Cursor issue

I've been trying to change my cursor theme to the Dracula cursor them everywhere around my system, but for some reason my cursor goes to the black default when I'm using a browser, and when logging in, it goes to the white default. How can I fix this?

At login, that is normal, since you have Not Yet Reached the desktop.

Some browsers supply their Own Cursor on some webpages. Usually, your default cursor should work on most browsers, though.
Which web browser are you using?


You are correct as I use Vivaldi and no matter which cursor I use it reverts back to Vivaldi's ..... PITA but it works ....

I'm using Brave browser. You're right tho, Firefox applies the theme to my cursor. So I don't get why Brave doesn't do the same.

How did you install Brave? If as a Snap or Flatpak, that may be the cause.

I installed using Snap. Maybe I should try using Flatpak

But also, is there a way for the cursor to register on my login screen?

Not that I know of from a setting... Prior to login, the user configurations have not been loaded. Because the user account has not logged in.

If you really feel inclined, though, you could replace the direct files for the default cursor theme with your preferred one. I have not done this... But now that you have got me thinking about it, I might just try it.

I've tried doing this, changing the cursor theme in the default folder in /usr/share/icons as well as changing the default cursor theme in my ~/.icons folder, but I'm still getting the default cursor theme at login. I'll have to keep searching for how to actually change what's shown at login

I am using Zorin OS Lite 16. I just successfuly changed the LightDM Login Cursor.
I do not know if it will work the same on Core...

But what I did:

I elevated File Manager to Root.
I then transferred my Preferred Cursor theme folder to /usr/share/icons

Then, I navigated to /usr/share/icons/default

I opened the Index.theme file in Text Editor. I changed the icon=Inherits value to the name of my preferred theme. Saved and closed.
I logged out - and there was my Preferred Cursor on the login screen.

1 Like

Oooops I just flagged this post instead of bookmarking it ..... :sob: :sob:

1 Like