Cyberghost vpn not working

Hello everybody... I know this topic has already been discussed in this post:

The thread is marked as "SOLVED" but I did not understand how... sorry!
If somebody could help it would be great.
I'm using zorin 15.3 based on ubuntu 18.04 and I encountered the same terminal messages as in the topic listed above.

Thank you!

That "Solution" is a bit hard to suss out, isn't it?
The O.P. noted that his current installed glibc version was lower than the required dependency in the Cyberghost package installer.

Can you paste the terminal output of

ldd --version

ldd version

here it is!
thank you!

If you are getting the error that Cyberghost requires glibc 2.29, this is the fault of Cyberghost, not Ubuntu. They did not properly create the installation package and check the dependencies needed.
The supported glibc in Zorin OS 15.3 is 2.28.

You do at least have the option of installing Zorin OS 16 now that it has been released, however. It is using glib 2.31 .... Assuming that Cyberghost did not set the Ubuntu 20.04 version to have a higher dependency than it actually has as well. :stuck_out_tongue:

It doesn't say anything about the glibc version I need...
when I try the installation, here is the outcome:

simone@spitocco:~$ cd Scrivania/cyberghost
simone@spitocco:~/Scrivania/cyberghost$ sudo bash install.sh
[sudo] password di simone:

CyberGhost Installer ...

No LSB modules are available.
No LSB modules are available.
Checking if glibc version is compatible
Couldn't detect a valid version of your distribution.
Make sure you have downloaded the correct install package for your distribution
Note: We support only the following distributions for Debian based OS:

-Ubuntu 16.04
-Ubuntu 18.04
-Ubuntu 19.04
-Ubuntu 19.10
-Ubuntu 20.04
-Linux Mint 19.2
-Linux Mint 20
-PopOS 19.10
-Kali 2019/2020 (glibc version should be 2.29/2.30/2.31 in order to work)
simone@spitocco:~/Scrivania/cyberghost$

When I contacted the cyberghost support, they told me that ubuntu 18.04 itself is supported, but not any ubuntu 18.04 based distro, because each one should need specific settings. I don't know if it makes sense, I'm not genius in tech stuff... :slight_smile:

Ah, got it.

It doesn't make sense. Because it's wrong.
Cyberghost did not write an install script - they reused an existing one. It's an easy fix - if you know how to fix it. Each distro does not need different settings. Nor is there any reason why they should.
I know, I am knocking Cyberghost a lot here. Cough.
Anyway...
The template script they used merely calls on existing Distros instead of recognizing Base OS.
You cannot change that, but what you can do is modify the script to say "Zorin" instead of "Ubuntu" and then it will run.
The reverse is also true: You could change your own lsb_release file to say "Ubuntu" instead of "Zorin", and the installer would run all the same.

The downside is, I cannot seem to get my hands on the Installer, since I would have to buy it- and I need to look at the files in the installer in order to give you details of what to change and where to look...

I can walk you through changing your lsb_release file (TEMPORARILY)...