D-link usb Wi-Fi adaptor not recognized

Hello everybody! I have an issue with my usb Wi-Fi adapter, I’ve tried any guide on the web but I can’t resolve. Hope someone can help me.

Hi and welcome to the forum.
Do you know what chip is in your USB wifi adapter?
Otherwise can you tell us the make and model and maybe we can find it.

Can you open a terminal and enter

lsusb

and post back the results please.

DWA-182 wifi stick ?

.
.
.
.
.

sudo apt-get install -y git build-essential dkms;cd ~/Downloads;
git clone https://github.com/cilynx/rtl88x2bu.git;sudo dkms add ./rtl88x2bu;
sudo dkms install rtl88x2bu/5.6.1;sudo modprobe 88x2bu;rm -rf rtl88x2bu/

Reboot, after installation has completed. Your wifi dongle should be active.

If you later wish to uninstall that RTL88x2BU driver: Open a Terminal window (Ctrl-Alt-T), and copy-and-paste the following command-line...

sudo dkms remove rtl88x2bu/5.6.1 --all

If your wifi still isn't working, post the text output of the following Terminal command-line...

clear;echo;dkms status;lsusb;uname -r

Still not work but is like it’s already installed.