Daily freezing and forced reboot

Are logitech mouses known to cause issues? I also have a logitech mouse and have been having identical issues to OP

I asked the O.P. of this thread if he is using a Logitech mouse in response to the libinput error he had also gotten. It is probably unrelated to the GPU issue.
The libinput error is also likely to be a False Alarm rather than anything to worry about.

@Bubby unfortunately the freeze did occur again :sob:

@Aravisian yes I do in fact have a Logitech mouse (MX Master 2S wirelessly connected via the USB Receiver).

I did somewhat recently install logiops to regain functionality of the thumb "gesture" button. As a precaution, I've just gone ahead and:

  1. Disabled the logiops service
  2. Went through and deleted all the installed files (that I am aware of at least)

I will see if doing that has an effect. I have kept Solaar installed however.

Unfortunately I do not have another mouse to test on (that wouldn't also be Logitech at least).

Dear beefchimi,

Just for the info;
I use the same mouse (MX Master 2S wireless). I use dual boot added the drivers from within Windows with the logitech app. After booting into Linux it all worked ok. I did not install the logiops service or Solaar, so I did not reassign the buttons.

Can't say the same about the gpu of course, but mine is an Intel Graphics as follows.

Screenshot from 2021-11-23 03-47-27

But reading the information you provided could it be that you installed extensions which could cause these frictions?

...What's the font? :woozy_face:

1 Like

Hahaha, you know... I've been fishing on the website you mentioned.

Wanted to let you know, but ehhh didn't wanna recall the old topic. Started scavenging the SciFi fonts found this one called Nasalization Regular. Works all through the system. Lower, upper and even the special characters. Even adjusted my grub, this because of the 4K screen.

Thank you for this, by letting us know about the dafont site. Found more to try, keeps me busy.

2 Likes

Dang, so I just hit the freeze again - so it likely had nothing to do with logiops. Here is another paste bin of the journalctl output:

Line 49 is where things seem to hit the fan. I appear to be running out of memory but I do not know what is causing it.

As per the advice in this thread, I will try to switch away from Gnome and see if that has any impact. Unfortunately, since I'm working full time on this computer, I am unsure exactly when I'll have the time to try switching DE.

2 Likes

@beefchimi with 32gb of ram I doubt it is Gnome. You would have to have some seriously intense work to use all that. What is running ?

I noticed right before everything goes haywire...you have express vpn? It's been a little while since I read up on VPN Services, but wasn't express one that was doing nefarious things....sorry...side thought. Anywho...whatever you are using the express for, you may want to try another....Nord is good (though slightly pricey). They have a free trial running once and again. I know they are sound, used to use them...think it runs out next feb. anywho...Try not accessing the VPN and see if that is what is causing your freeze.

If it is the VPN, you may really want to consider another or checking the config. It takes a lot to use 32GB RAM. I usually have slack, code, firefox, evolution, zoom and terminal going...running updates and all...never pass 20GB with a server running. Yeah...try all that without the VPN.

Edit: BTW, KDE is one command to install, takes maybe 3 minutes. Configuring it will take you a few days....there is A LOT to configure (depends on how custom you want it).

Also, you may want to check older journalctl to see if it always happens around the vpn.

1 Like

@Bubby honestly I'm never running all that much when a freeze occurs. The most significant thing would likely be Firefox + Brave with a bunch of tabs open. Beyond that, I'll have my terminal window open and VSCode.

I do game on this computer quite a bit. I have had the freeze occur once while playing The Binding of Isaac. Interestingly - its never froze/crashed while playing Doom Eternal :rofl:

@337harvey yea I noticed the expressvpn entries as well... I'm guessing that's just because expressvpn gets added as a startup application when you install it? I honestly rarely ever turn on the VPN, and havn't done so in about 1 month.

To play it safe, I've just gone ahead and uninstalled expressvpn for now. I will give it some time and report back a new journalctl output if/when things freeze.

Good to know that KDE is a quick install - but since I work on this computer, I will likely have to wait until the weekend before I try installing it and getting things configured :slightly_smiling_face:

3 Likes