Daily freezing and forced reboot

Starting only about 1 week ago, my computer has been freezing and locking up, forcing me to reboot.

The computer typically freezes during work hours, when I've got the following apps up and running:

  • MatterMost
  • VSCode
  • Gnome Terminal
  • Files
  • Firefox
  • Brave

When the computer freezes:

  • If there is audio currently playing, the audio will start repeating that last half second or so.
  • My cursor will remain in place, but if I move my mouse around, after about 10 seconds, I might see a tiny bit of movement of the cursor onscreen.
  • I cannot alt + tab to anything, force quit, etc. Everything appears to be completely locked up.

I have been achieving a reboot by:

  • hold alt + printscr
  • press r, e, i, s, u, b

After the most recent freeze + reboot, I immediately ran the following:
journalctl -b -1 -e

Here is the output:

I am no expert on parsing this information. There are a few things in there that could be culprits? This line in particular is interesting:
/usr/libexec/gdm-x-session[3659]: (EE) client bug: timer event2 debounce short: scheduled expiry is in the past (-5ms), your system is too slow

My specs:

  • OS: Zorin OS 16 x86_64
  • Kernel: 5.11.0-40-generic
  • Monitors: 3 connected, with primary monitor running at 3440x1440@100hz via DP
  • WM: Mutter
  • CPU: Intel i7-4790K (8) @ 4.400GHz
  • GPU: NVIDIA GeForce GTX 1080 (also have Intel HD Graphics)
  • GPU Driver: 495.44
  • Memory: total 31984MiB

If anyone can offer advice I would greatly appreciate it.



What is your system specs?

1 Like

@Bubby apologies for not including this! I've edited my OP to include the specs.


I would suspect this first.
We lately have several members having problem in interaction between integrated GPU and discrete GPU.

1 Like

Pull up terminal and type this: sudo apt update & sudo apt upgrade

@FrenchPress is there a way to disable the Intel HD Graphics so that only my GPU is active?

@Bubby I went ahead and ran the commands exactly as you provided.

Foolishly, I restarted my computer without pasting the output :sob:

There were definitely some packages that appear to have been updated. Not a lot, but a few. I don't recall anything specific though.

1 Like

This thread may help:

1 Like

Could you tell me which version of NVidia driver you are using?
I remember some members did have some issue with 470 (propitiatory, tested) driver. I am OK with this driver since I have no integrated GPU.

after update (and I know it's early to tell) is things working better?

I believe he stated 495

I missed that :sweat_smile:
So the drive is not the issue.

1 Like

Try a different DE... gnome has been causing many issues as of late... may i recommend KDE or cinnamon?

My specs are very similar to yours, using KDE i have no issues. I left gnome installed, just never use it. Since the gtk framework exists, it's usable (all currently installed apps and extensions) while having the option and benefit of QT as well.

My RAM on idle is between 2.4 and 2.8 GB in use... not to much more than gnome (without the leaks).

Since gnome is so restrictive and trying to be for Linux what windows is... you may find it beneficial to switch. You can find a how to in the tutorials section of the forum.

Or XFCE :mouse2:

His machine would support all of them....kde wouldn't be that much a difference (until he opens the settings... similar to xfce but everything is listed and customizable mostly graphically) from gnome.

1 Like

Indeed. It is a matter of one's taste.
I mentioned XFCE since @Aravisian is expert at it :slight_smile:

1 Like

@FrenchPress thank you for the link, I'll take a look and see if this GPU switcher makes any difference.

And as @Bubby confirmed, it is the nvidia-driver-495 (proprietary) version which is installed :slightly_smiling_face:

@Bubby yes to early to tell if the problem is fixed, but it has been happening consistently every day for the last week... so I think if I can go a full day of work tomorrow without freezing, I'll be throwing a celebration! :partying_face: Will report back my results.

@337harvey I will look into the tutorial you referenced - thanks for the suggestion. I will hold off however until I can confirm the freeze is still happening after performing the update + upgrade that @Bubby suggested. I will report back if/when I switch DE.

Thanks again to everyone for jumping in to offer advice so quickly! :pray:


Your welcome @beefchimi , hopefully the issue is fixed. look forward to your reporting back ... so we can use this info for future users. G


Logitech Mouse?

1 Like

And you say we think more of your abilities than your abilities actually support. :wink: