Dark themes with blue text bug

Every Dark theme a install from GnomeLook have a problem, they show a blue font in apps Menu.

When using dark themes i want the font to be white. I think it should be the default font color.

Whe I use default dark Zorin theme I dont have this problem. It happens only with personalized themes I download from internet.


Anyone knows how to solve this issue?

Welcome to the Forum!

You placed Your Theme in ''Shell''. This seems to be a Bug or something with Thrid-Party Themes. When You use it only in ''Applications'' it should work. For ''Shell'' You could use ZorinGrey-Dark. Then You have white Fonts.

2 Likes

thank you!
this problem happens only whe use themes in Shell.
ZorinGrey-Dark seems to be a good workaround.

1 Like

...LibAdwaita at work.

2 Likes

Could be, but don't have to. I tried it in the Past on Ubuntu 22 LTS and there wasn't an Issue like that. But Ubuntu 22 has Gnome 42 not 43. Debian (which has Gnome 43) I haven't tested yet.

It is in the Quick Settings or the Calendar in the Taskbar, too. The built-in Zorin Themes don't make a Problem. I tried to put the Theme in the /usr/share/themes/ Path to look if this change anything but no.

Okay, I tried it with SpiralLinux (Debian 12 with Gnome) because I had the ISO here and it works. If someone should use Debian 12 with Gnome directly, please share here if the Shell-Theming works.

None of the themes I tested worked correctly.

In addition to the problem mentioned, Chrome/Brave and I suspect any other chromium based do not uses the theme. It is necessary to config the Browser to use GTK (Preferences -> Appearance). Even so, when saving a downloaded file, the save window does not use the same theme, even though it is the system's default window (nautilus).

Interesting that Zorin's theme is applied correctly.

Do you use for Chrome/Brave the Flatpak Version? If yes, the Theme doesn't work by default because Flatpaks run in a container. And there they have only limited Permissions. When You use it as a .deb file it should work - as far as the Theme Settings for an Application goes.

No, I don't have anything installed with flatpack. I installed it via .deb.

It only works if you configure the browser to use GTK. And then it happens to not apply the theme at all. For example, when saving a downloaded file, the destination selection window is left without a theme.

However, it's not important for me, I can use the default theme. Just to illustrate that changing themes is not as simple as it should be.

Edit: I use wayland. Changed to x11 e same behavior.

1 Like

Maybe a Reboot helps? Did you tried that? I mean set in Brave to GTK and then make a Reboot and look if it works.

Yes, tried a reboot.

With GTK enabled, the browser assumes the theme. Except for the file save window.

Interestingly, a Nautilus window invoked by browser are unthemed. When Nautilus is opened directly are themed.

Another point, why does the Zorin theme work, even without configuring the browser to GTK?

There is some configuration in the themes that Zorin themes is applying while others are not.

That is a good Question. One Point could be that the zorin Themes are in a different Path. There are in the /usr/share/themes/ Path. I tried this Path in the Past to look if it works better but in my Case it didn't worked. You could try it. Maybe it works for You.

Yes, are in this path.

I put it in this one because the other path doesn't even exist on my machine, and all the themes (including the natives of Zorin) are in this one.

In order for independent distros to theme their distros in their own styling when using Gnome, in spite of LibAdwaita, special scripting is required to essentially disable the tight controls LibAdwaita imposes. While I cannot verify which ZorinGroup used/uses, the arch repo contains a copy of a package that prevents LibAdwaita from specific theme interference.

This is tricky, since Gnome and LibAdwaita are closely integrated and inter-dependant.

I would suspect that this is why Zorin OS themes work while third party themes are having trouble.

1 Like

Maybe it is because the Zorin Team put Gnome 43 in Ubuntu 22 instead of using the normal Gnome 42. Maybe the Zorin Team should take a Look at this.

By default it shouldn't exist. You have to create a themes Folder and an icons Folder in /home/[Your-User-Name]/.local/share/ and then put the Theme or Icon set in the Folder for that.

But to use the usr Path is totally okay, too.

1 Like