Dash to dock suddenly gone?

Hey all, I installed Dash To Dock about a week and a half ago when I first installed Zorin. It was working fine until yesterday. I went to open Spotify and instead of the dock sliding down when a full screen application is launched, it just disappeared with no animation, I didn't think much of it. Ever since this however, Dash To Dock has not returned. I don't know how to to get it back, I also have not removed any files form Dash To Dock.

I think that would show up in your extensions list. Perhaps it is not "enabled"?

Have you tried Reinstalling Dash To Dock?

I've never noticed that setting before, nor did I have to enable it when I installed it the first time. Nevertheless, when I enabled it, it came back however it is now different. There are no opening/closing programs animations, nor is there any animation when it hides from a full screen window and there is no option for a floating dock with rounded corners, it's now only a rectangle.

Also, it only shows up when I enable it directly from this website (which I didn't have to do before) Dash to Dock - GNOME Shell Extensions

I am unable to, as whenever I am trying to make the install, it spits out the error

sassc --omit-map-comment _stylesheet.scss stylesheet.css
msgfmt -c po/de.po -o po/de.mo
make: msgfmt: Command not found
make: *** [Makefile:90: po/de.mo] Error 127

Interesting... but it worked before?
You might try

make -i install

instead of make install

Or try

sudo apt install gettext

Both of these commands seem to have installed it without any issue, but they still don't actually make Dash To Dock show up. Also, now after entering these commands, when I go to Dash To Dock settings, I get this error: https://imgur.com/a/RuGBmSd

sudo apt install --reinstall zorin-os-desktop

If still having issues,
check ~/.config or ~/.local/share/gnome-shell/extensions for any files on dash to dock and move them to a separate directory (just to back them up). Place them in ~Documents, if you want.
Log out and in, then test dash to dock.

I tried the second option you listed and now Dock To Dash does not show up in Gnome Tweaks. It has been changed to how it was before however, with "Zorin Dash" now acting as the Dash To Dock menu (including floating rounded corner setting like I originally had it). It still doesn't show up though, I also reset the Gnome Shell.

I do not use Zorin Core (Gnome), I use Lite.
So, I cannot verify this at this moment but - Is Zorin Dash providing the same function as Dash To Dock?
If so, then having both installed at the same time may create conflicts between them.

1 Like

Well when I originally installed Dash To Dock, it would use the "zorin dash" menu instead of creating its own for some reason, however it worked completely fine like that with both of them on the same system. It's weird that this issue arose completely out of the blue.

I can confirm what @Aravisian said. Having Both docks will conflict with eachother. Tried it, read the book and got the T-shirt :stuck_out_tongue:

1 Like

Zorin Taskbar is based on Dash To Dock, so it makes sense that it causes issues.

Cairo dock may work better with the customizations you want. I'm not sure if all of the animations and customizations are the same, been a while since i used it.

Since I don't use Dash To Dock either, I'd suggest changing its settings to not conflict with Zorin taskbar, for example if Zorin taskbar is set to hide after a full screen activation you can't set Dash To Dock to stay in view after the same condition. It's clear that if one of the 2 taskbars doesn't take exclusive control the other one applies its own configurations making disasters.

To avoid this stuff in the future, set up a backup tool and the next time something breaks just revert to the state of your PC yesterday or previous boot

So then why would it work before? I can't figure this out.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.