Davinci Resolve not working

I installed Davinci Resolve and whenever I open it I get an error that says
"Unsupported GPU Processing Mode
Please review th GPU drivers and GPU configuration under preferences"

I have a Lenovo IdeaPad S145 with an AMD Ryzen 5 3500U and an RX Vega 8

it all worked fine on windows, its really just on linux that it's not working well (it had the same issue on Linux Mint)

Hello and welcome to the forum.

Did you follow installation guide like this?

2 Likes

I tried it now, it's still giving me the same error

Unfortunately, I have null knowledge regarding this particular application.
I hope other volunteers @Storm or @zabadabadoo or @337harvey could help you with this issue.

1 Like

Familiarity may be important.

But looking over that application, I can see a variety of other concerns. I do not know if you are using the paid for version or not, but there are many good, solid native Linux apps for color correction, picking and editing on Linux.
I wonder if using a natively supported Open Source app may be your better bet.

2 Likes

I go to film school and it's important that my software work with the rest of the team's (I keep a dual boot with windows pretty much just for that, but it'd be better to have everything on Zorin which is what I use most often), and there's also the familiarity factor as you said, I have given a look into Kdenlive and Natron, they seem like good options but would definitely need a while to transition to them.

1 Like

Does the guide above provide any pointers to what may be wrong?

When it comes to Windows Apps like above that are not native, they get vbery hard to troubleshoot. The indie devs don't always think in the same terms as Linux devs on Error Reporting.

Another option for you would be to run the Windows Application on Zorin OS using WINE;
Just download the Windows .exe file and double click it on Zorin OS to start the Zorin Windows App Support installer and configuration tool.

1 Like

I read the guide here, and it is actually how I initially installed before trying @FrenchPress's, as for wine I didn't even think about it to be honest, I can try but I'm a bit concerned about doing it that way, would it come with any performance or stability cost?

Olive maybe an option; https://www.olivevideoeditor.org/

If you got the money lightworks is pretty cool; https://lwks.com/guides/how-to-install-and-uninstall-lightworks-for-linux/

2 Likes

never heard of Olive but I do like the interface, apparently it is in its nightly builds, is it stable? I have to work with very large projects for very long sessions

Performance cost? Probably not. Stability - I do not know.
You can check on the WineHQ forums for the rating of that app or to seek pointers. I have never used the app, much less used it on Wine, so I cannot comment and would not want to mislead you.

2 Likes

Or search here:

Crossover is a paid version of Wine. It uses the same engine as Wine.

1 Like

It has been nightly build forever. I only use it for small things, so I can't say if it's a big project.

1 Like

Use this link this works I have studio install work just fine . you do need a NVIDIA card or the the amd pro drivers

2 Likes

where can I find amd's drivers? I never seem to find the equivalent to my computer

You must download and install from the AMD website. AMD, sadly, is not very supportive of Open Source. :expressionless:

I thought it was NVidia which is not very supportive.

caution: age restricted :wink:

Nvidia has a history of not being supportive of Open Source. A lot of antagonism between Linux and Nvidia. But it has improved a bit- in part thanks to Windows.
But AMD is worse. They ignore Linux more than Nvidia.

2 Likes

apparently there are only windows 10 drivers available to mine

1 Like

The drivers in the kernel are your only option, then. Or the Obiaf Drivers...
Can you elevate to root:
ctrl+alt+t to open terminal, then:

sudo -i

Launch the file manager

nautilus

Navigate to /etc/X11/xorg.conf.d/ and right click an open area, select create new document
Name it 10-amgdpu.conf

Paste the following into it:

Section "OutputClass"
Identifier "AMDgpu"
MatchDriver "amdgpu"
Driver "modesetting"
#Option "PrimaryGPU" "No"
EndSection

Save the file and reboot to test.

1 Like