DD/DTS Decode NOT lit up - How to configure correctly please?

Hello All,
I am new to Linux/Zorin. At the weekend I was Googling for a Linux distro for an old laptop I got, Zorin was mentioned on Reddit so after some research I decided to try it absolutely love it. I am so pleased, I paid for the Pro version (if only to support them) and decided to ditch Windows11 and now have Zorin OS 17 Pro on my main PC. If I had only known how easy it was to use I'd had switch over years ago!

Now, to the (only) problem I have encountered:
How to enable HDMI/SPDIF Passthrough in VLC so that Dolby Digital & DTS audio (music & MKV video) is makes the 'Decode' LED light up on my Logitech Z906 5.1 Audio system which is connected by optical cable to the Optical output of my Asus Prime Z-370A.

Previously on Windows I had the same issue but it solved by enabling it in the Audio settings of VLC:

However, in the version 3.0.21 VLC I installed from the Zorin Software store (including all available Add-Ons) there is no such option under Audio settings, as shown here:

The default audio device is set to Digital Output (S/PDIF) and I do hear sounds, but only rough sounding stereo, and not the crystal clear awesome sound with the DD/DTS Decode lit up as I did before.

To be honest, even regular stereo music via Tidal (Web Player as no app for Linux apparently) doesn't sound too great either.

I hope this makes sense. Could anyone can help me sort this out please? I'd be eternally grateful!

Thanks and kind regards,

Andrew.

Hello, you may try the app(s) like pulseeffect/easyeffect and also adjusting the sound by using app like pavucontrol.

1 Like

Hello All,
Just to update that the issue is solved, the problem was me... :o)
I didn't realise I had to restart the PC once I'd installed the VLC Add-Ons, set the Pulse Audio Volume Control > Output Devices > Show Advanced > Checked DTS & AC3. I tested with BluRay Rip of Bowie Hammersmith Odeon 1973 and it sounds amazing, with the Decode LED on, indicating it's working as expected now.

1 Like