".deb cannot be downloaded securely" and "exit code 127 error"

Hello,

I recently reinstalled Zorin 16 on dual boot Lenovo Ideapad and have come across an issue I've never encountered before on my previous installs.

Any attempt to download a .deb file on Microsoft Edge failed: "cannot be downloaded securely", and clicking the three dots and "Keep" does nothing either. I've googled "ubuntu 'cannot be downloaded securely'" but found nothing.

When I try the same on Firefox, it downloads, starts the Software Center, attempts to install, and "exit code 127 error" pops up. Googled it, and found this:

It's rather daunting for me, to say the least.

Perhaps there is an easier way to solve the issue? Any input would be appreciated.

Thanks!

I should mention that I was able to download and install Microsoft Edge deb from the Microsoft website earlier, using Firefox. The failed attempts were Vypr VPN, and Master PDF. Thanks!

Just for me to understand better, you:

  1. could not download the .deb for Edge from a non-MS website using Firefox
  2. later managed to download the Edge .deb from MS using Firefox
  3. cannot download any other .deb on Edge
  4. managed to download Vypr and Master PDF . deb on Firefox but they don’t run.

Did I get these correct?

Assume you have downloaded the .deb to your home directory, can you try sudo dpkg -i <packagename.deb> without the <>?

2 Likes

Also, my own naive question: Is Secure Boot enabled in your BIOS settings?

1 Like

You should search "Can not download securely using edge on ubuntu or linux". What you're experiencing is an Edge issue, not a Zorin issue, if I'm reading what you're writing correctly.

It is most likely a setting within Edge that MS turned on that you will have to find and shut off. If it was at the OS level, you wouldn't be able to download on any browser.

2 Likes

Sound like Microsoft wants to discourage Linux in that way.

It was some big disscussion if you installed Edge then you cannot installing another things like your Edge is primary. Simple is remove Edge and then everything back to normal.

1 Like

Thank you for your reply; my apologies for being unclear.

  1. On a fresh Zorin install, I used Firefox to go to Microsoft web, and I downloaded AND installed MS Edge .deb with no problems.

  2. I then proceeded to use Edge to download Master PDF and VyprVPN debs, but "could not be downloaded securely" and the three dot "keep" feature didn't do anything either.

  3. So I tried using Firefox to download both .debs. Clicked yes to install, and it started the Software app, attempted to install, but gave me the "exit code 127 error".

  4. UPDATE I tried again just now, and somehow Master PDF was already installed. I can't say how that happened, as I'm absolutely positive it wasn't installed the last time. Vypr VPN still failed though, on both Edge and Firefox.

Please note that I've installed Zorin at least half a dozen times on several laptops and never encountered this issue before, for the same apps (Vypr and MasterPDF).

As to your question, I checked and all the debs and "unconfirmed downloads" were automatically downloaded to the Download folder, and not Home.

Thanks for your help!

For the downloaded debs, you can install them using:
1.sudo dpkg -i ~/Downloads/<packagename.deb> or
2. sudo dpkg -i and then open the Downloads folder, select a deb and drag it into the terminal and the path will autopopulate.

For Edge, I suspect it will block other files, not just debs. It just happened to be that you noticed it first with debs. Likely something in its download or security settings. You may want to ask on an Edge forum as well about this issue.

3 Likes

I never knew this!

Hello,

Update: Attempted to install Startup Disk Creator in Software Center gave me the same 127 error message... but I rechecked, and it actually installed. So anyone who encounters the same error should just double check.
I also randomly installed Zenkit just to see what would happen, and it installed with no error message whatsoever.

I should have also tried to use Synaptic to see if it worked.

Still haven't solvedmy issue with installing .debs downloaded from websites, but will keep you all updated.

Thanks!

Doing a search on the error itself, I came across this:

This may not directly provide a solution, but I do wonder if it is a clue as to what is going on.

Kubuntu 20.10 has broken QApt package manager and this has been a lifesaver...
I consider that my favourite command to run in the terminal.

OP seems to have discovered it already...

@vipertongue make sure you have set the update server to "main server" if you haven't already..