Default Audio Output Device

I recently purchased a Blue Yeti Mic and the built in sound card sets it's self as the default audio output device when booting Zorin 16.2. I have installed the pulse audio control to switch the default to the builtin speakers post boot.

I located the following instructions to affect a permanent change and though I have followed them to the letter many times have had no success.Does anyone have any insights on this particular problem?

My Devices:

david@d-box:~$ pactl list short sinks
1	alsa_output.usb-Generic_Blue_Microphones_2138BAH0GGQ8-00.iec958-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED
2	alsa_output.pci-0000_00_1f.3.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	RUNNING

Is this a Bluetooth device or hardwired?

Looking at the Blue Yeti website, the mic is USB type.

It is USB and because the mic has a builtin sound card it is seen as an audio output device. Pulse audio sees it as an input and output device.

Some things to try, if you not done so already by yourself:

  1. try discionnecting then reconnecting the USB mic when system running to see if then detected.
  2. Try a different USB port.

Next.
In terminal type: alsamixer
Hit [F5] to show all channels.
Post a screenshot, so we can see what that tells us.

Also look for Muted channels etc as per this post: Playing music over internet Like stereo mix - #10 by zabadabadoo

The mic is detected and working , but sets its self as the default audio output device@boot and I have switch to the builtin speakers manually via sound settings or the pulse audio volume control. I'm trying set the builtin speakers as the default audio output device.That is what lead me to the instructions I posted.

Solution: Located the audio default sink configuration in home/.config/pulse.
Replaced : alsa_output.usbGeneric_Blue_Microphones_2138BAH0GGQ8-00.iec958-stereo

With: alsa_output.pci-0000_00_1f.3.analog-stereo

Saved file and rebooted.

1 Like