Deja Dup could not restore the files, please make sure that you can write it

I lost my OS then I installed new one, now I'm trying to restore the data from the backup I have on my google drive,the problem that after restoring it says

How I can write it ? as I understood that I need to give permission on the system files.

Wondering if this is the issue?:

I was wondering if the backup was from the deleted OS and it is looking for that?

The backup I made 4 days ago when my old OS was normally working, the more problem that now I can't use the backup at all not restore files to original locations and not to specific folder

Are you running deja dup from terminal with sudo?

didn't try yet
should I use this command duplicity deja-dup --restore file

You could also try taking ownership of the folders and files in those locations in your $HOME? Some people don't like to do large operations like that but $HOME should generally be considered a safe place to do an ownership change.

I'm not 100%, but the duplicity manpage might help. ( Or $ duplicity -h )

Before restore, did you install for use by a different user name than what you used on ZOS16? Or the same user, but different password?

excuse me I didn't get the point

I made the username the same

Some backup and restore utilities require that your "new" OS user info must be the same as that which was used during backup.

as I understand from the deja dup message that the problem with permissions, the file system read only that's why it can't write over the system files

From my understanding, deja dup process (during restore) does not have permissions to write to /$USER/$HOME

that's the problem + no permission for etc sys usr

Also, you mentioned you're restoring from a file via Google drive. Any chance you tried downloading file first before starting restore process? Or did you set it up for the restore process to pull the file from an online source?

I downloaded the files and will try to restore from local files

I think a #sudo restore would help you.

Note Organic Marble's response.

when I tried to restore from local files

What happens when you run sudo deja-dup in terminal?

just opening the deja dup GUI

Can you try restoring the same local file?