Dell Firmware Updates Might Be Missing in Software?

Normally in Gnome, I can see that it is providing firmware updates for my specific Dell XPS 13 model. I do not see that in the zorin gnome software.

I tried to fix this by installing uefi-uw-tools from the software store -- but now when I go to update the software store it throughs an error "AppArmor policy prevents sender..." that's clearly blocking fwupd.

Does ZorinOS have it's own automatic way to make sure the firmware & BIOS can be kept up to date on my specific laptop (Dell XPS 13 9300)? If so, is there a way to check to make sure that is working? If not, is there a workaround, given that installing uefi-uw-tools is not working?

I see other options in software include gnome-firmware, and fwupd. Not sure if one of those should be tried/used?


Hello kcdah, welcome to the forum. I understand your frustration and appreciate the details you have already provided, but there are a few things we would need to assist you. Would you mind telling us which version of Zorin are you using? Since you say gnome software, I imagine it's core or ultimate, but the version number will be important. If it's 15.3, that is based on Ubuntu 18.04, if 16 Beta, it is based on Ubuntu 20.04. Any earlier versions may be working well but wouldn't have the updates, so I'm guessing one of the first two I mentioned.

If you're dual booted with windows on another partition you could perform the update easily there. Once you respond with the version you're using I may be able to research something that will help.

oh sure, sorry I forgot to mention that! Zorin 16 beta -- so Ubuntu 20.04 based

You may want to follow this how to by the dell support team

I found through the following link:

There are also terminal commands to check and update the bios if possible on your system. Looks like you'll be downloading the driver to usb and installing from the bios itself though.

Please be sure secure boot is off. I know it's a "duh" thing, but it happens to be missed on occasion.

1 Like

Thank you! The terminal commands were nice. Looks like everything IS up to date. Hopefully that means that ZorinOS16 does it automatically -- I just can't see it. But regardless, I can always do the terminal commands.


For anyone else's future reference for ease:
sudo fwupdmgr get-devices
sudo fwupdmgr get-updates
sudo fwupdmgr update


Dell recommends, and Ubuntu uses, fwupd by default for the updates. I would use this utility because of Dell's recommendation. Not having a Dell myself makes it impossible for me to recommend any other solution for you. As with "Etcher", make sure to test and prepare for some issue. Though most of the time the recommended will work without problems, it does happen. Thank you for posting an easy to access reference for others.

1 Like