Dell G3 3590

Hello, guys!

I searched for 3590 and nothing was found, so I think this is not a duplicate topic.

After having Ubuntu giving me a hard time on my Cell G3 3590, I found out that despite being sold as Ubuntu compatible, it is not. There are many topics on Dell's forum about that.

I know Zorin OS is based on Ubuntu but I would really like to try Zorin OS and I did not find anything specifically about that on Google, so here it goes:

Does Zorin OS run normally on a Dell G3 3590? :crossed_fingers: :crossed_fingers:

You can test it yourself in the live USB environment, make sure you test everything. If you have problems, you can list them here.

5 Likes

I actually came here to look for answers, not to give them :rofl:

But, fair enough, this is the machine's info:

I'll bring the news here, then. When I find anything not working properly (or to my liking, like these Ubuntu things I describe below) I will update the post.

I'm testing it as a third OS and it's doing great apart from those 2 boring things also present in Ubuntu:

  1. Media keys on keyboard take 2 secs to actually do the action when at first, then they keep responsive for a while.

  2. Similarly to the above, the Windows (forgot the real name) button takes a while to finish loading that panel with the apps. At first as well.

.....

When I use the space bar to preview a document and click on the X to close it afterwards, the preview window opens again, so I have to close it for the second time.

After not using the keyboard for a while, it seems to be on standby mode or so, because when I start typing it takes a while to compute all the key presses. After that it works ok.

I can't use accents. I am Brazilian, so I do use them quite frequently.
This is what I get: n~ao, `a, sa'ude, etc.

When unlocking the screen, the desktop does not appear smoothly, the top of the screens lags behind and it tears (in lack of better words)

.....

Dota 2 run fine with the default NVIDIA installation on first boot. :smiley:

1 Like

Oh my gosh, I really don't like Dell's website. I tried to look for some SPECS on that computer, and all I found on Dell's website was a giant overview of features, with a annoying chat with us for support box that keeps popping out and hiding, and no SPEC sheet to speak of on there.

And if you look at the page just long enough, it doesn't take long to realize, that Dell is trying to bank on the hopes that you will buy their accidental damage and service and support warranty's. The only place on their page where we might find some honesty, is in the reviews at the bottom.

And even that is spotty at best, cause were not really going to know which reviews are planted and which ones are not right. The page is just not professional at all, I am just amazed how bad it is. Then I tried to click back, and their site wouldn't let me do that.

So off I go back to Google on a new tab, looking for the SPECS. OK, now to a real website who knows what they are doing...

CPU: Intel Core i5-9300H
GPU: NVIDIA GeForce GTX 1660 Ti (Laptop)
Display: 15.6”, Full HD (1920 x 1080), TN
Storage: 512GB SSD + 1000GB HDD
RAM: 8GB DDR4, 2666 MHz
Weight: 2.34 kg (5.2 lbs)

Pros

Low price
Good performance, given the hardware
Comfortable keyboard
Great upgradeability
It has an SD card reader

Cons

No Thunderbolt support
Only 52% of sRGB coverage (BOE T1WD3-NV15N3D (BOE0819))
Uses aggressive PWM to adjust screen brightness - our Health-Guard profile fixes that (BOE T1WD3-NV15N3D (BOE0819))
60Hz panel has uneven Luminosity (BOE T1WD3-NV15N3D (BOE0819))

At the end of the day, this is a mid-range computer with a core I5 CPU, and its got a 1660 TI GPU, which is a more modern version of what used to be the 1650 GPU in these things. It comes with a 1080P screen, but for 15-inches, you honestly don't need more then that!

Its got 512GB of SSD for the boot drive, which is stellar, and its got up to 1TB of mechanical storage, which is more then enough to install a lot of games. This machine only has 8GB of RAM, for gaming that is not great, but I'm sure it can be upgraded!

Going off SPECS alone, this machine seems pretty decent to me. If he can upgrade the RAM to 16GB, he will have a very decent gaming machine that is gonna be able to play most games. It would struggle with games like Shadow Of The Tomb Raider, Control, Metro Exodus in anything higher then LOW settings though.

From what I can tell, its not a bad machine, but I don't trust the folks who made it though. But Kedric is right, I don't own a Dell, I certainly don't own that Dell machine, so there is no way that I could tell you how well it would perform on Ubuntu.

But looking at the SPECS, technically, it should handle most Linux distro's as long as they arn't too heavy. But of course, thats only an assumption, cause I don't own a Dell, cant say for sure, pure an educated guess is about the best that I can do.

1 Like

Boot takes a long time, literally minutes.

It shows says something about a starting job on the disk with the uuid of 60a832ae-a528-4f65-b5e8-35ce2061dc60, so it has something to do with the swap partition.

This is what the cat /etc/fstab

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=99f6e781-b66a-491a-ac41-142877d80e6b /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=6FC8-7D40  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/sda2 during installation
UUID=60a832ae-a528-4f65-b5e8-35ce2061dc60 none            swap    sw              0       0

Any ideas on what it could be?

1 Like

Since I cannot edit the other reply any more, will reply that with some news.

Using Gnome DE to enable Bluetooth works fine just like it does in Fedora (it does not work in Endeavour OS).

Bluetooth tool lists too many unknown devices, nearly 20. The computer sits on the same place it has ever been, and no other OS shows so many unknown Bluetooth devices.

1 Like

Not quite yet, but I have an idea. I want you to type in terminal...

systemd-analyze

Please post the results here.

Basically, I want to know the times that your computer is taking to do everything to boot up into the OS.

For reference, here are my numbers when I run that command...

Startup finished in 8.173s (kernel) + 14.862s (userspace) = 23.036s
graphical.target reached after 14.835s in userspace

2 Likes

Thanks for the quick reply, @StarTreker !

Results of systemd-analyze critical-chain

The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @1min 38.844s
└─multi-user.target @1min 38.844s
  └─networkd-dispatcher.service @1min 30.688s +492ms
    └─basic.target @1min 30.671s
      └─sockets.target @1min 30.671s
        └─snapd.socket @1min 30.670s +478us
          └─sysinit.target @1min 30.662s
            └─systemd-backlight@leds:dell::kbd_backlight.service @3.946s +88ms
              └─system-systemd\x2dbacklight.slice @2.120s
                └─system.slice @537ms
                  └─-.slice @537ms

Just systemd-analyze

Startup finished in 5.142s (firmware) + 3.526s (loader) + 34.388s (kernel) + 1min 38.859s (userspace) = 2min 21.916s
1 Like

That 38-seconds into the userspace and 34-seconds into the kernal are concerning. That just seems far too long.

uname -a

I assume when you run that, were going to find that you are using the 5.11.36 kernel correct? Well, I suggest we role back the kernel and try that.

From machine off, hit power button to turn machine on. 2-seconds after hitting power button, hold down the shift key until GRUB loader comes up.

Now go to advanced options. And then initiate a kernel override with the 5.11.27 kernel if its available. Try that and see how you boot. Post new results as well with the systemd-analyze.

1 Like

I was on thirty-something, yes. Not sure if 36, though. Changed to 11 and the result is the same, even the message about the starting job on that drive.

Startup finished in 8.303s (firmware) + 10.285s (loader) + 3.122s (kernel) + 1min 39.179s (userspace) = 2min 891ms 

1 Like

2-minutes!

No, something is not right. I assume you have the OS installed on an SSD correct? Even if the OS was installed on a slow mechanical drive, I would expect boot into OS no more then a minute.

Your going to need Aravisian to help solve this, as I have no clue at this point. At least I helped in getting more info which Aravisian or someone else can use to help you further.

1 Like

The elimination of these two can help.
Check if you are using any snap packages, first.

snap list

You only really need networkd-dispatcher.service if you are running a server, so:

sudo systemctl disable NetworkManager-wait-online.service

1 Like