Dell Lattitude 5590 keyboard no more backlit

Hi folks,

Had the good fortune to get myself a brand new laptop from old stock at the beginning of the week. It's a 2019 Dell Latitude 5590, which had never been out of its box. Price was a pitance, and it's a nice improvement compared to my previous laptop, more or less 10 yo already.

Had two surprises as well : Windows was not installed, and a backlit keyboard.

Installed the latest Zorin Os right away, probably my smoothed Linux install ever. Everything is working from scratch, even the silly joystick, right in the middle of the keyboard, and even the "calc" key, right above the keypad. Never seen that key, it's a first for me, and I've been dabbling with computers since 1983...

But... the keyboard is no longer backlit, and I've no idea how to set it back on.

It's not a real problem, but it's a nice feature. Anybody has a suggestion to remedy that ?

Thanks a lot !

Some development... No idea why, nor how, but the keyboard just lit itself a few minutes ago... Puzzling ! I can't figure out where the hell the change does come from. I had just modified the screen light and suddenly, KAZAM, my keyboard was bright as day.

I won't complain, but I've yet to figure out how to set it on or off... Any ideas, people ?

These magic happenings are more expected with sound issues than keyboard backlight. I hope it stays lit and well behaved if you have put your genie back to bed.

Yeah, sure. Keeping my fingers crossed, but would very much prefer something that acts less randomly...

In my laptop latitude E6430, i can control it by using Fn+Win+ Left or Right.

Thank you but, on my laptop it just switches between desktop.

The keys I'm supposed to use are : Fn+F10, problem is : sometimes it works, sometimes it doesn't.

It could be your keyboard issue.

Can you elaborate, please ? All key combinations work as they're supposed to, except this one, which is erratic.

I meant a technical issue, sometimes some buttons don't work until you press them a little too hard.
It also happens to me.

Ok, I see and had the same idea, tried but not sure it helps

Checked if any firmware updates were needed. Applied them, but no change, still the same erratic behaviour : on without touching anything, off just the same, required key combination is useless most of the time, and can't get anything from the command line...