Denied acces zorin-menu@zorinos.com folder

I tried to replace the gray zorin start button with the blue zorin logo but am denied access.
What can I do to get around this

I'll be honest, this is something that I've not tried before. But I'm guessing that if you have that location open in your file manager, you aren't allowed to create a folder there or anything like that by default?

If so, you'll need to elevate your permissions and copy it that way. Probably easiest to use the terminal with the CP command (at least it would be for me).

Maybe this isn't the issue, but I'm just going off a hunch right off that bat.

You are right, as far as I understand I should have root access and I don't. However, I have read how to change it with terminal, but I'm not too sure about it as I'm a newbie and afraid of making mistakes

That's perfectly fine to be concerned. It's something more people should be wary of.
Luckily, there's plenty of resources (and people) to help. So in this case, it's a very simple command that you'll want to be doing:

sudo cp [file] [directory]

So in your case it's going to be something like:

sudo cp /path/to/file /path/where/file/go

Doing sudo will ask you for your password and then it will do what you wish, so it is slightly dangerous, however in this scenario the worst that can happen is you copy a file somewhere that maybe it shouldn't go and can be easily deleted if need be.

EDIT: By default unless you add sudo you won't have root access. This is a safety measure so that people don't go adding or removing things that could possibly do more harm than they know

sudo cp /Download/zorin-icon-symbolic.svg /usr/share/gnome-shell/extensions/zorin-menu@zorinos.com
I know I'm doing it wrong because I get an error message, just don't know what
don't know if I should have Home before download

Sorry that's my bad, I should've realized that.

To make this a little easier, what you can do is open the file manager to where your file is (in Downloads), and then right click on empty space in the file manager in that location and click open in terminal.

And from there, you should be able to enter:

sudo cp zorin-icon-symbolic.svg /usr/share/gnome-shell/extensions/zorin-menu@zorinos.com

However, like I said before, I haven't actually done this myself, so If there's a better way to do what you're trying to do, someone else would have to come in and lend you a hand haha. I'm just under the assumption you are replacing the old image with a new one.

1 Like

this is exactly what i am trying to do but so far no luck. Thanks for trying to help me

Easiest way to get blue Z logo for the menu is to install the Midnight theme and apply that through Tweaks:

Get the theme from here:

2 Likes

Try (the tilde is shorthand for the home directory):

sudo cp ~/Download/zorin-icon-symbolic.svg /usr/share/gnome-shell/extensions/zorin-menu@zorinos.com

1 Like

You missed the ~ which denotes the user's Home directory. The Download folder is inside the Home directory so you need to specify that:

sudo cp ~/Download/zorin-icon-symbolic.svg /usr/share/gnome-shell/extensions/zorin-menu@zorinos.com/

I will recommend you take a backup of the original file that you are trying to replace. Just in case if you change your mind in future to get the default ones.


If you don't like to use terminal then you can use nautilus-admin

sudo apt install nautilus-admin

Relaunch your file manager when done. Now right click on the folder, you will see an option Open as adminstrator/root. Now you have the full access to the folder.


Another option could be directly launch file manager as root (I don't recommend this, if nautilus-admin works for you)

sudo nautilus

Note: Be-careful while accessing the root directories. A wrong move can cause error to the system.

3 Likes

Yes, now it has changed to Blue icon, but the one on the taskbar is still the gray one. I have read in a previous post that there are several places with various icons, so now I just have to find the right one
Thanks for the help

2 Likes

The grey icon is a Symbolic icon.
You may need to look to see what the shell theme is calling on in the css file.

Yes, I noticed that, I'm not sure I want to do anything. I also found, in addition to the one shown in this thread, another script but I'm a little nervous about making mistakes

Using Zorin OS Lite is a different experience. I can change the whiskermenu icon from the settings for the menu. Or the Zorin OS Menu-Lite just by changing the zorinmenulite icon in the icons folder.

You are right, the Gnome-Shell is much trickier to theme.

especially when you don't understand what you're doing :confused:

1 Like

This is an experience I suspect we can all relate to.

Far too often, in these threads and in Zorin OS/GnuLinux, I feel utterly no understanding of the underlying code or how it works.
It's constant learning.

2 Likes

is there a zorin os lite pro? just installed Zorin OS Lite

There is indeed a zorin os lite pro, but zorin os lite / pro 17 is not out yet, still only currently 16.3.
Hopefully it shouldn't be too much longer, I'm eagerly awaiting that release.

1 Like

oki! Thanks

@jerik, if using Zorin OS Lite, you can install the whiskermenu with

sudo apt install xfce4-whiskermenu-plugin

Once installed, you can add it to your panel:
Right Click the panel, hover over Panel > Panel Preferences and click.

Click the Items tab
Click add item and scroll to the bottom of the list to click on the Whisker Menu

Position it where you want it to be using the up and down arrows on the right side of the Items Tab Window. Up moves to the left and down to the right on the horizontal panel.
You can add a separator if you want between the menu and other items. If you do, you can expand the separator by clicking on it in the Items Tab, then clicking the gear Settings Icon and selecting Expand.

With Whiskermenu added, you can right click on the menu.
Click Properties.
Click the Panel Button tab.
Click the Icon: button to change the icon. A popover window will appear that you can navigate to your desired icon location.