Desktop Copy / Paste on Nautilus Gnome

I have the exact same problem and it is very frustrating. Is there really no way to fix it? I don't like the nemo desktop (files and folders' names are not in line with dark theme) so if anyone could find a better way to address this I'd appreciate a lot.

What exact problem do you have ?

1 Like

Can't copy/paste from desktop to nautilus/from nautilus to desktop. Here is a quick video showing the issue: Gofile - Free file sharing and storage platform

Sorry for it being italian but I have my Zorin installation in italian language. I click the copy option (copia) for the img in nautilus and then try to paste it to desktop but paste option (incolla) is greyed. The same vice versa.

2 Likes

If you do not have dconf-editor installed, you can install it with

sudo apt install dconf-editor

Can you please launch dconf-editor and navigate to /org/nautilus/desktop and look at the value for ignored-desktop-handlers.

1 Like

I have no "nautilus" folder in /org


I have /org/gnome/nautilus and no "desktop" folder in here

But I do have a desktop folder on /org/gnome/desktop
and I can't find the value "ignored-desktop-handlers" in the folders here

I will need to log in on Gnome desktop to check this out... Unless another Gnome user wants to explore this in the meantime.
Have you tried the dconf-editor Search Function?(I notice your cinnamon entry - search may lead you to Nemo).

Yes I tried the search function but I find no "ignore-desktop-handlers" value

Using Gnome I've tried to find it, hope this is the right place, but I'm not sure
perhaps with a print screen you can confirm.

Screenshot from 2021-12-14 11-19-26

If so,type - handlers - in the search option this should lead u to the place shown in the print.

1 Like

Yes I found it and it is disabled. Should I enable it?

I believe that this issue has not to do with nautilus.
Because I use Dolphin and face the same issue.

Even though the location shown in dconf editor has nothing to do with the file manager, but the desktop, one would suggest that your at the right place, but guess what, I also changed the option to > enable - but it didn't work for me with Dolphin. I even restarted my system ( wasn't necessary).

But you can try. If it doesn't work, you now know where to find it and put it back to the disable value.

1 Like

It's not working but thank you anyway :slight_smile:

Searching, I found this:

Doesn't appear to by any progress to-date - just a "maybe fixed in Nautilus 4". Oh well.

We were able to suss out a way of getting it working with Nemo, which is why I asked about handlers. But that lacking in Nautilus, I currently at a loss.

It appears to work using Drag n' Drop, but not when using the context menu options.

Using Dolpin, drag n drop from desktop to folders works but vice versa does not.
To both ways (desktop>folders or folders>desktop) copy/paste does not work. I can relate why your at loss.

But still all is not lost.
I can use the option copy to within Dolphin and so is the case when using the standard file manager which comes with Zorin.

And I think that user
Desktop-Not-Working can confirm that, am I right?

I confirm I can "copy to" Desktop too. Anyway it's not a suitable workaround :laughing:

If i remember correctly you have to install gnome tweaks to gain access to desktop icons extension, which is off by default. Turn it on and you'll be able to copy paste to the desktop (or in the desktop directory). You may be able to find it in the system settings, but i haven't a clue where to look for gnome extensions there.

Enabling/disabling desktop icon extension doesn't change anything. I also tried installing the gnome-desktop-icon-ng extension and disabling zorin-desktop-icons but still can't copy paste to desktop from nautilus.

Hello, Desktop-Not-Working

I was referring the copy to as a (ultimate) result because even after adjusting the settings in dconf editor, Aravisian was trying to address to a certain link which could help. As he said mentioned - current at loss- doesn't know how to look any further.

I know that it's not a suitable workaround, but I don't mind this problem because don't place my documents or folders to the desktop, and because it can not be resolve (yet), I'm am willing to use the copy to option. :yawning_face:

2 Likes

Video link updated

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.