Desktop Freezes randomly

Issue
My notebook gets stuck randomly even when performing common task like document editing, web browsing etc. etc.
This happens to me several times a week and there is no particular pattern i ever observed from years.

What’s Not Working

  • In Scenario 1, Alt + F2 combination works so that i can fix with xkill command,
  • In Scenario 2, nothing works, no matter how hard you try.

What’s Working

  • Only way to get system working is to do Force Shut Down.
  • Mouse cursor is working all the time but isn’t able to trigger any action.

Issue happens again on 11 Dec, 2020 at 14:09
System Log
Kernel Log

Try these, in order:

  1. Let us know what are your highest CPU & memory consumers using System Monitor.
  2. Switching drivers (if any are listed) under Zorin Menu -> System Tools -> Software Updater -> Settings -> Additional Drivers
  3. GUI Laggy slow response after updates
  4. Post the output of sudo lshw -c display

I also had this issue, since my system has only 4 gb of ram running heavy applications like android emulators etc would render my system unusable and then I had to forcefully shutdown my pc (by holding the power button).

Running htop at the time to monitor the usage will give you a good idea of what application is resource hungry. If your pc is old then it is a good idea to run the lite edition instead of the core though.

2 Likes
  1. CPU and Memory always remains below 50%. There is no resource hungry app running.
  2. In additional drivers section, there is only one intel network driver. (I am Ryzen user)
  3. I haven’t enabled it
  4. *-display
    description: VGA compatible controller
    product: Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
    vendor: Advanced Micro Devices, Inc. [AMD/ATI]
    physical id: 0
    bus info: pci@0000:03:00.0
    version: c4
    width: 64 bits
    clock: 33MHz
    capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
    configuration: driver=amdgpu latency=0
    resources: irq:53 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:e000(size=256) memory:fe700000-fe77ffff

I have fairly good 1 year old notebook with 8GB of RAM. This much should be enough for web browsing or document editing.
Here I am uploading complete report of my computer.
Click here to see report

Update : Sometimes, when rebooting Notebook after Freeze, it redirects to busybox which shows filesystem error. I bypass it everytime using fsck /dev/sda4 -y
My friends discovered this issue in lite edition also.

It occasionaly happens to me now when I use libreoffice too. Don’t know what is happening. I am using an ssd with encryption enabled.

Can you use Synaptic to tell us if you have the following packages installed?

  1. xserver-xorg-video-radeon-hwe-18.04
  2. mesa-va-drivers
  3. mesa-vdpau-drivers
  4. mesa-vulkan-drivers
    If any of those 4 are not installed, please install them.

If this still doesn’t help, in terminal (ctrl+alt+t), please run sudo add-apt-repository ppa:oibaf/graphics-drivers and then sudo apt update && sudo apt upgrade

Personally this happens to me very rarely, but when it does I don’t completely shut it down now. Instead, keep on pressing the power button in between, which makes it to restart itself.

This will clear the memory and any unsaved work will be lost

1 Like

All the 4 packages are installed but i am still getting freezes, sometimes back to back.

Whenever desktop freezes, it disconnects me from meeting. Restarting whole process wastes important 5 minutes.
For document editing, there is less pain because of document-recovery feature of libreoffice.

Just remembered that I get occasional lock-up’s on Core. I have always got out of them by attempting a log-out, but not actually logging out.
The appearance of the log-out/switch user window seems to revive the session.
I think I get to the log-out screen using Ctrl+Alt+Del or something when screen is frozen. I’m not on Zorin right now to test that.

Please be mindful of your posts. I have bolded the part of your response that is disrespectful toward another poster and thereby a violation.

I edited my post.
However, my intention was not to disrespect to the person who is trying to help me.
I use those words for irritating desktop freeze problem which occurred since zorin 15.1
@carmar
@CatNoir

I tested all key combinations.
There is variation on type of freezes that occur.

  1. Mouse scroll moving but no action can be triggered both from mouse or keyboard.
  2. Screen completely freeze but reboot again get it working.
  3. Screen freeze and after reboot it redirects to busybox where i need to solve disk error using fsck /dev/sda4 -y

Every desktop on which i installed is getting at least one type of freeze. I can’t understand where the problem is.

Some more suggestions here:

  1. Some suggestions on BIOS settings: https://forums.linuxmint.com/viewtopic.php?t=285701
  2. https://www.reddit.com/r/Amd/comments/8gxn42/raven_ridge_support_ubuntulinux_is_it_any_better/ and also https://www.reddit.com/r/Ubuntu/comments/85vav4/how_i_installed_ubuntu_1804_with_ryzen_2200g/
    I noticed disabling dpms among the many suggestions. I know yours is a laptop but see if disabling the blank screen does anything. There are other suggestions you can try here too but the kernel one doesn’t apply and oibaf was already tried by you.

I do get 1 and 2, never had the third one though. Have ran fsck many times (with live usb) but no change.

It’s fine, never mind :slight_smile:

This was a problem with Ubuntu 18.04 in the past (with old kernel)
See:
https://medium.com/@gspasov2/how-to-fix-ubuntu-18-04-lts-random-freezes-52bb75d55c70

also:

https://www.linuxquestions.org/questions/ubuntu-63/ubuntu-18-04lts-freezes-randomly-4175635188/page2.html

EDIT: When I ran virtualbox today and the whole os froze, I tried console switching which seems to be working:

ctrl+alt+f1 (will make the screen blank)
ctrl+alt+f7 (will bring back the screen)

I read your suggestions and tried them as well.

  1. Updating Kernel
    I am already on kernel 5.4
  2. ctrl+alt+f1 & ctrl+alt+f7 both tried during freeze, none works. Moreover, in 3rd type of freeze even Magic SYSRQ fails to respond.
  3. I have no problem running fsck but the thing is that disk blocks are getting damaged or duplicated + it takes lot of time.

Same, I am also on kernel 5.4, It is better to let fsck run on the disk completely as there might be some filesystem corruption or something?