Desktop icons disappeared

Hi everyone, I’ve been using ZorinOS for a few months already and so far it’s been great. Today when I started my computer I encountered an issue that actually already happened once before, but didn’t report it (as it fixed itself by restarting the computer).

The issue is simple and only a bit annoying, not a big deal but since it’s the second time already I’d like to report it here and see if I can learn something new (and of course, fix it).

So the problem is that the desktop icons are all gone, they simply didn’t load when I turned my computer on. Note that they’re only the icons, I can still access the files in ~/Desktop from both the terminal and Files (the file manager/explorer). I already checked that I’m not in the wrong desktop but I’m not quite sure what could be the cause or how to fix it, so I’m here asking for some help :slight_smile:

I’m currently running Zorin Core 15.3, but I’m not sure what other information I should provide please let me know what else do you need.

Screenshot from 2020-10-26(2)

Thank you!

Can you try reinstalling one or more of these in Synaptic (see screenshot) and see if that fixes it? Try the zorin-desktop-session package first.

Hi carmar, thank you for the help.

I have reinstalled all three packages as suggested, one by one first and then all three at once, but without any difference at any point. Am I suppose to restart my computer afterwards (last time this happened to me it fixed it without having to modify anything)?

I wouldn’t think restarting is necessary but you could try it. Can you try zorin-appearance in terminal and change to one of the other two layouts and see if that helps?

1 Like

SOLUTION: Toggle “Icons on Desktop” off and on again under Zorin Appearance.

I’m just putting this up here to make it obvious for anyone else who might have this issue. But switching between themes and layouts didn’t work and in fact I even got this error in the terminal:

/usr/lib/python3/dist-packages/zorin_appearance/ RuntimeWarning: Unable to read properties of /sys/class/power_supply/hidpp_battery_0: [Errno 2] No such file or directory: '/sys/class/power_supply/hidpp_battery_0/present'
  warnings.warn("Unable to read properties of {0}: {1}".format(supply_path, e), category=RuntimeWarning)

The screen did a little “flickering” while reloading things but as I said no difference. That’s when I noticed the toggle to show/hide icons on Desktop, which was already on, but I decided to toggle it and see what happened and it fixed it.

If you need more information, logs, etc I’m happy to provide them if it helps to fix this little issues.

And thanks again for the help. I’ve noticed a couple of threads of admins leaving recently and it’s a shame but your work is really helpful and much appreciated. It’s just that people like myself don’t come by often to say how great things are working most of the time :slight_smile: