Desktop icons not appearing, and other major problems

My XFCE (zorin os 15 lite) doesn’t look very cool. My desktop icons are not showing, the close and minimize buttons (besides the window title) are not showing, I can’t use some shortcut keys, and some interfaces are not displayed correctly. I leave photo below.

Close buttons and window title not appearing:

Desktop icons not appearing:

And, opening the settings and going to “Desktop”:

Completely weird. It was like that after I added my sister as a user. When I log into her account or another, it seems normal, only for my user who is like that.

Thanks for any help.

Edit1: switching the session between “Zorin OS Lite Desktop” and “XFCE session” the result is the same.

If you log into your account, where the issue is, open alt+F2 and enter in

xfwm4 --replace

and see if the window borders and Titlebar and Titlebuttons show up.
This is not a solution, but to see if XF Window Manager will work, to try to diagnose.

1 Like

It worked now. I’ll see if I can log back in with the desktop by restarting the computer.

Ok, if that worked:

Try the following: In your ~ folder (/home/$USER), right click the .config directly and rename it to .config-bkp. This is to create a backup of your configuration directory in case you need to pull needed configurations from it that are Not related to the Desktop Environment itself.
Now, do the same thing with your .cache directory.

Remove (Move to trash) both of those directories, then log out and log back in or Reboot in order to auto-create new .config and .cache directories set to default- and test that everything is working.

I restarted the computer multiple times and it looks “ok” as before. From what it looks like in your answer, I must remove the two directories that I had renamed. If I do that I will lose relatively important application settings, won’t I?

You will not permanently lose them because the first step is to create a backup of each.
The .cache folder is most likely safe to remove. it’s just the cache - temporary storage.
You May Not Need to remove the .config directory. If by replacing xfwm4 as before, then saving session by rebooting and booting into that New Configuration- the problem Might Be solved. But I do not know that for sure so am being thorough. If you are comfortable with waiting to see how everything works before removing the .config directory- that is fine. If another reboot sees the problem return- You know now how to fix it.
The .config directory may have settings you do not want to lose. By replacing it with a default .config, you can narrow down the problem for sure. Then copy over what you need for Other Settings (not related to the missing Window Manager settings) from the .config-bkp.
For now, you may be fine not renaming a backup and removing the .config folder. But if the same problem returns, you can do it then and then copy your needed settings to the new .config directory.

1 Like

Sure. I’ll mark your answer as a solution, thank you so much!

1 Like