Desktop Layouts Disappeared

My desktop layouts have disappeared. Because I don't change the layout often, I'm unsure when they disappeared. Following the advice of another post, I tried

sudo apt install --reinstall zorin-appearance && sudo apt install --reinstall zorin-appearance-layouts-support

but it had no effect, even after rebooting.
Any thoughts about other things to try?
Thank you!

p.s. I'm running Zorin OS 16.2 x86_64 with the Adwaita theme

Zorin OS Core or Zorin OS Lite?

ZorinOS Core (Gnome)

You might also include:

sudo apt install --reinstall zorin-os-desktop

Thanks for taking the time to reply; I really appreciate it.
Unfortunately, the suggestion didn't solve the issue (assuming I don't need to restart; I haven't done that yet.)

You can try alt+F2 and enter in r
Or restart to refresh the desktop.

Restarting didn't help :disappointed:

And you reinstalled zorin-layouts-support...
This is an odd one. It's like finding dinosaur bones at the fleamarket instead of in the field - you are not sure of the origin.
You may have done an autoremove command or a package removal that removed dependent files at some point.

You might have a .config file that is interfering. You can test this by

mv ~/.config ~/.config-bk

Restart and check your system. Once you do, you may see changes due to your Custom Configurations now being stored in bk (Back Up) and the configs all set to default.
But if it helps your current issue, you can then sift through your config-bk folder and transfer to ~/.config anything you wish to keep. I suggest moving one a time in case you move the thing that caused layouts to disappear... And I point out that this suggestion is a shot in the dark - I am not knowledgeably aware of any config file known to cause this issue.
It's just that ~/.config files can cause mysterious issues sometimes.

Well, that certainly changed how things look :smile:
The Layout screen is no longer blank. It's got the "Get more desktop layouts" heading, with drawings of additional desktops, along with buttons to upgrade, learn more, or not show again. That's better than a blank screen, certainly, though I'm still not seeing the ability to change the layout.

Clicking on the drawings of layouts should be the method to switch between them.

No, I was seeing the images and text that normally comes after the images you're talking about.

I've decided, at this point, to just reinstall Zorin. My data and apps, for the most part, are on a separate partition. I've reinstalled Linux distros so often I've got it down to a science now :slight_smile:

I really appreciate your help. It's a weird issue. Even though we haven't figured t out, your suggestions are good. So thank you again!

1 Like

I'm not 100% certain, but I'm starting to think the issue is/was ultimately related to the issue in this post.

1 Like

I would say that is good thinking. You know far better than we do what actions ahve been performed on your computer.
You can try

sudo apt install --reinstall fonts-zorin-os-core zorin-desktop-session

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.