Disable a touch screen permanently and random mouse clicks

Hi everyone, relatively new to Zorin and Ubuntu etc.

Version of Zorin: Zorin OS 16 Pro; single boot
Hardware HP Pavilion x360

This laptop has a touch screen issue (hardware related, it occurs when in BIOS as well) where the pointer randomly moves and clicks to the point its not usable.

In Windows the touch screen could be disabled in software, which worked round the problem effectively.

Issue 1: Zorin 16 Pro has been installed however there appears no UI setting to disable the touch screen. Google led me to xinput - and xinput disable NN. This works - but only for a single session.

Q1 - how can I make this setting persistent?

Issue 2: Even with this setting to disable the touch screen, regularly the laptop still does random right-clicks (every few seconds). This did not occur in Windows. The touch pad has been disabled in the UI with no effect. It occurs with and without a USB mouse attached.

Q2 - any ideas on what may be at play here, and any thoughts on a solution??

thanks in advance

On Q1, some suggestions:

On Q2, I'm hoping that gets fixed when Q1 issue gets permanently fixed.

1 Like

Thanks @carmar

I've tried this approach from the second link

If that does not work (or you don't have permissions necessary to edit system files), get the name of your touchscreen with xinput and add one of the following commands to a startup script:

xinput set-prop [touchscreen name] "Device Enabled" 0
xinput disable [touchscreen name]

I did this through adding a command to Startup Applications Preferences. If I run the command(s) manually they do disable the touch screen.

But they don't seem to automatically run on re-boot?

Regarding q2 at this point the random mouse clicks continue after manually disabling the screen.

Are there better options I should try?

The second link best answer suggests editing 40-libinput.conf, as does this one:

Did you try editing that file?

I have now, and its disabled the touch screen after a reboot! Thanks.

(I just need to do the UPDATE bit now).

Thats the good news, not so good is the random mouse clicks are continuing. While I understand there is an underlying hardware fault here, I'm hoping there is an equivalent software tweak noting in Windows this stopped when the touch screen was disabled in software.

Do you have Screensaver or any settings in Power manager that automatically disables the display after a certain period of time?

Thanks for the suggestion @Aravisian . I have changed the following as a result

  • Turned OFF Dim Screen When Inactive (was ON)
  • Set Blank Screen to Never (was 5 minutes)
  • Turned OFF Automatic Suspend (was 20 minutes when on Battery Power)

No screen saver.

The random clicks still happen :frowning:

Anywhere else I should look?

I suspect poor hardware - even Windows 10 users having different issues with same Notebook:

I know it was a different issue but wonder if installing hwe kernel might help?:

change 16.04 for 20.04 in the accepted solution.

Had a thought, when I boot into Zorin 16 Lite off USB the Mouse and Touchpad options differ from Pro.

Under Device I can select my USB mouse, touch pad and the ELAN (touchscreen) and each has its own toggle screen.

Disable the touch pad and the ELAN - things work perfectly (after 15 mins testing!).

These settings are not in Pro ... how can I mimic these settings in Pro?

1 Like

Thanks @swarfendor437. Tried the accepted solution - "Linux-generic-hwe-20.04 already at the latest version...". Zero upgrade, new install and remove.

No change to behaviour.

Really curious about what I found in this post where it seems to work on Lite.

You cannot unless you use Pro Lite.
Gnome and XFCE are different desktop environments. You may just try using Pro Lite...

1 Like

I'll give that a go I think and report back!

Thanks @carmar, @Aravisian and @swarfendor437 for your time and suggestions. Pro Lite is working well, so while not solved its an adequate work around!