Disable spring loaded folders

Anyone know how to disable “spring loaded folders” ( Folders opening automatically when i hover over it with something I am dragging into it).

I deal with lots of pictures that need to be distributed between lots of different folders quickly. When I drag the picture files across I need to travel down the list of folders to find the relevant folder for that set of pictures to be dropped into.
Real pain if I linger just that bit too long on any of the folders as they “spring” open and the files are dropped either there or to another random folder that I can no longer see because the “sprung” open folder now obscures everything else!

***Please be gentle with me I am a 2 week veteran of Linux and a slow learner!

I’m using Core with the default layout and this doesn’t happen to me, so you may be:

  1. Using Lite - in which case, please wait for someone else to opine.
  2. Using a different layout - in which case, go Zorin menu -> Settings -> Appearance -> Zorin appearance -> switch to one of the other layouts and see if that takes care of your issue.

Thanks for the reply.
I’m also using Zorin OS Core 15.3 and the default Appearance. Tried switching to the other 2 layouts and still the same.
On one of the layouts it did seem to give me a bit more time before the folder sprung open but not nearly enough.
Only happens when I’m holding something with right click while dragging?
Any other ideas?

"Only happens when I’m holding something with right click while dragging?
Any other ideas?"

…oops that should read LEFT CLICK! (told you I was a bit slow!)

Spring loaded folders.
I love that name.

I use Zorin Lite and it has been a while since I used Gnome. I have never experienced this… But then, you know… Gnome…
I had to look this one one up. Apparently, it is just another case of Gnome not being user friendly. Yes, you can disable that “feature” using a gsetting since Gnome does not include it in the Nautilus Preferences.

WHY would such an absurdity be enabled by default and WHY would they not place that setting in plain sight?


1 Like

That’s the ticket!!!
“gsettings set org.gnome.nautilus.preferences open-folder-on-dnd-hover false”

Typed the above directly into terminal (which is what I assume command line is?) and it simply worked!

You don’t know how happy you have made me!
If it wasn’t for social distancing I would give you a hug!

1 Like


Either that, or the fact we probably live thousands of miles apart. Virtual high-fives for everyone.

Interestingly, dconf-editor shows that setting enabled for me and yet I don’t have the same issue.

@Aravisian - I’ve noticed that dconf-editor hasn’t been as helpful in resolving similar settings issues. Thoughts?

How long do you helicopter that mouse over that folder?


mv ~/.config/dconf/ ~/.config/dconf.bkp

and reboot - test.

Helicoptered for 10 seconds - then got bored and stopped.
Deleted the config files, rebooted. Setting still on.

Have you tried hitting it with a hammer?

That would only improve the quality of the answers on this forum. Why would I want that?

No big deal - I’ve been wary for a while of recommending dconf-editor solutions - I’ll keep to that.

It should not be that way.

I will research this more when time allows.

Can you post the result of:



and your default File Manager?

Nautilus. Everything is default for me.

I have no clue. Some settings for gsettings must be set as root- some for the user. But why it is you have something enabled but it has no effect and you say it seems most gconf-editor settings have no effect…
-shrug- beats me.

I have tried many different keyword searches but the problem itself is a bit vague so- I have turned up nothing of value or at least nothing neither of us do not already know.
Let’s hope Zorin 16 arrives soon, already.

No worries. Thanks for trying.