Disable Zorin Connect?

I installed Zorin Connect to try it out. I didn’t care to have the notifications from my phone popping up, when I was running the same app (in this case Telegram) on my desktop. I decided to uninstall the app from my phone, but I’m still seeing Zorin Connect notifications on my wake screen.

Is there a way to completely disable it as if I’d never set it up in the first place?

Can you try Alt+F2 and type dconf-editor? If that doesn’t work, sudo apt install dconf-tools in terminal and again try the Alt+F2 and type dconf-editor.
In the new window, navigate to /org/gnome/shell/extensions/zorin-connect and toggle the ‘enabled’ button. Then close this window and see if that disabled it.

If that doesn’t disable it for you, uninstall the package completely (Synaptic or sudo apt purge zorin-connect). Although, with this approach I don’t know if there are unintended consequences.

The Zorin Connect toggle was already set to disabled. I’m considering purging it, but as you said, perhaps there would be unintended consequences.

Worst case scenario, you can always reinstall after purging. I see zorin-connect folders in the home folder under .config and .cache (press ctrl+H in Nautilus to show hidden folders). You can try deleting those folders to see if that does it.

There’s also the option of Settings → Notifications → Zorin Connect set to Off.

Even after completely purging zorin-connect, the notifications were still coming. This was what I had to do to actually remove the notifications (strangely).