Discord not working

Hello. I have before installed discord was working. Today i get update discord.deb package i download from website but not working. Something changed or many things stop working. One is fixed pipewire working correctly I have now sound when starting Zorin. Don't need using settings to choose correct output sound.

Did you check the compatibility of the new package against Zorin? Best to use Gdebi to ensure all dependencies are met before installing 3rd party .deb packages.

1 Like

Well on installation I don't find any problems. When start installation on Zorin after that nothing happens.

I know why i cannot install discord and why isn't working. Don't have installed flat and snap. I don't know why debian don't working before was working.

Flameshot also noty working. So I guess any .deb not working.


It is updated but not started what happens?

You could probably do a sudo dpkg -i #discord deb and tell us what errors come out.

When I put your command in terminal it gived me information i need some argument what is archive. On aptitude I have information this installation must be forced. Second information i have this package is closed and cannot seeing a code. So no open source.

Besides Flameshot printscreen application also not working. So any debian package isn't working? When I tried find discord on installation package in Zorin software I have information nothing found. I wrote before I have uninstalled flatpak and snap package from my Zorin but why .deb also now not working? It is frustration for me when something working properly before and now not working. I don't get that. I don't installed any some many software what could gived some errors package. Only using updates mostly. What happens with Zorin?

I couldn't even guess what happened here.

I would reinstall the OS in such a disaster.

Yes I am also confuse. How it is possible? Steam and games working. Firefox working and vlc and pipewire working correct. No idea what anything else could be not working. I know people sayed in linux what I have mostly program is for standard using. I don't installing anything more. I know only from guide here uninstalled package flat and snap. I can trying checked if my files not corrupt with recovery Zorin.

I found one problem discord need libc++1 trying finding in aptitude but nothing found. Flameshoot still not working.
sudo apt-get install libc++1
E: Could not get lock /var/lib/dpkg/lock-frontend. It is held by process 5089 (synaptic)
N: Be aware that removing the lock file is not a solution and may break your system.
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?

Ok. How i fixed that. I uninstalled discord. Then used aptitude to install lost package lib++1 then download discord deband installing not from debian gdebi but use linux installation software from zorin right click mouse on file discord-0.0.18.deb then choose open with help and next Install app linux.