Disk mounting question

How do I tell the difference as my ZOrin 16 does not mount but if I sudo mount -a it does manually its in fstab okay and works on some other pc's I have but for some reason its doesn't mount after reboot. Can you give me more details as to how I check to see if they are "enabled" already, if not which one I would need to "enable" ? and what is the command?
Sparkey70

Hello and welcome to the forum :slight_smile:

Since you posted in the already solved thread, I created a new thread for you. This way, it will attract more volunteers to help you with your issue.

1 Like

I'm not sure i understand your issue. Would you mind going through it with me, please be specific. The more info you provide the better I'll be able to assist you.

Edit:
It sounds like a permissions issue, but I'm not quite sure if I'm understanding correctly. Are you accessing the share from a windows or Linux machine?

2 Likes

I solved it by adding the entry in to the FSTAB file
It is a windows cifs share

sudo nano /etc/fstab

added x-systemd.automount 0 0 to the end of the line made the mount stick

//IPADDRESS/Media /mnt/servermountname cifs _netdev,username=xxxx,password=xxxxxxxx,dir_mode=0777,file_mode=0777,uid=0,gid=0,x-systemd.automount 0 0

3 Likes

Yes, the terminal can be used to edit the FSTAB config, and I am sure many Linux pro's and experts would jump at the chance to terminal everything to their hearts content. And, I am glad the resolution worked for you in that regards.

Having said that however, newcomers to Linux, who come from Windows, this will not be a fun experience for them. There is another way to do this via GUI, and that is using the DISKS utility, that comes loaded with every standard sized Linux distro.

Turn OFF automatic mounting. Put a check mark Mount at system startup. This is especially useful for external hard drives, which is what this specific setting was used for in application.

2 Likes

I never knew there was such a thing! I VERY much appreciate the tip and the DISKS utility!

Sparkey70!

1 Like

What do you mean by this?

Normally I just add the line into fstab and it always gets used at boot.

There is, something like, systemctl restart mountd, to get it to scan fstab and recreate the systemd mounts.

If I use it just like so:

//IPADDRESS/Media /mnt/servermountname cifs _netdev,username=xxxx,password=xxxxxxxx,dir_mode=0777,file_mode=0777,uid=0,gid=0 0 0

It does not mount. At first I thought it was the network not starting fast enough I added the _netdev and still no go.. Added the x-systemd.automount and it then mounts every time. If there is something I missed let me know what to try. Currently I'm trying to understand the DISKS utility.

Sparkey70

On DISKS how so I mount a CIFS share? Any links to videos on how to do it?

Sparkey70

I think sharing is set in Samba, not in Disks.

Open Nautilus file manager. Right click on a folder you want to share, click properties, go to the Local Share tab. From there you can enable the folder and files in it for sharing. There are video's on setting up Samba sharing.

Thanks for that. I guess I did not ask the right question my fault completely. I was able from my Zorin PC mount a CIFS share with FSTAB. Every time I boot I can get to my data via /mnt/media folder. The Media share is on another machine (windows). Is there a GUI app that does the same thing as the fstab file or is the only way to mount is via fstab? Its okay if the GUI based app modifies the fstab for me. I thought DISKS did that but it looks like it only mounts local volumes.

Because of the way that Linux is secure, I am not sure if there is a way to have network connected drives auto mount. I have always just double clicked on them to mount them.

I posted gigolo (GUI) in the above for automount network drives.
Here's another tutorial:
https://www.unixmen.com/how-to-access-remote-linux-and-windows-shares-with-gigolo/

2 Likes

Creating a symbolic link to the networked folder may assist in the automounting of the share at boot. It is the same thing that is done in windows in order to have a network share mount on boot.

And you could teach us all how one makes a symbolic link? :wink:

1 Like

ln -s /source/directory/or/file /output/directory/or/file

1 Like