Display Color Revert To Default Configuration Until I Restart Nvidia X Settings

Hi, Zorin Users or Developers!

I have Nvidia graphic card running my display with the latest driver installed on my system. I always use color correction to compensate my cheap bright monitor, which brightness is already in its minimum value. Here is my X Server configuration:

Here is the problem: it reverted to default value [0.0, 0.0, 1.0] under some specific action until I restart X Server App. Here is some action I've found that revert my configuration:

  1. Modify (copy, cut, paste, delete) files from nautilus. Modifying files from terminal does not trigger this problem.
  2. Opening videos with Zorin's default video player.
  3. Playing YouTube videos inside Firefox.
  4. And typing any letter inside Gedit (as you can see in this GDrive video)

This condition occurs one time per session, but with 100% success rate. For a while, I thought this is Nvidia's Driver limitation, but using Kubuntu makes me realize it is not. So I thought this is Gnome's Limitation, but I cannot remember this happening inside Pop OS. So, here I am, thinking this might be Zorin's.

How can I stop this to happen?

I hope my problem is clearly outlined. Thanks for reading this long

Does it appear when downgrading the nvidia driver (I guess you use 510) - To rule out driver issue.

Yes, I use 510 because it is what is suggested by default. This is the option that I've chosen:

Will that version able to runs this script below?
image
Or, will there be any drawback, overall?

either try the latest 515 or 470 (or try both), they should have no problem running the script.

Okay I'll try. Thanks!

Tried both and nothing changed :sweat_smile:

This is a shot;
Try write the changes into .nvidia-settings-rc instead of /usr/bin/nvidia-settings.

Hmm, I don't understand your instruction… Are you talking about the script that I wrote? Or, are you talking about something else? Could you elaborate further, please?

Yes, try writing the configuration locally (home directory) instead of globally. In your home directory is a file called .nvidia-settings-rc.

Mine look like this:

See if editing this file keeps the configuration you want.

Ahh, now I know what you're initially suggested. Unfortunately, this file is already inside my home directory, and it has been saved with the same configuration as in the X Settings.

Then it most be the version of Gnome Zorin uses that is bugged. I'll see if google comes up with.

Hi, Storm! Thanks for your help... But I think you don't have to do it. Let me google it if this is still necessary because I found a workaround.

Last night, I accidentally found another trigger which is opening Discord application. :sweat_smile:

So, in order to fight this once-per-session condition, I came up with an idea to make a startup script that lets discord start view second and then kill it.

This is the command that I came up with:

#My ordinary Setup
nvidia-settings --verbose --assign CurrentMetaMode="HDMI-0:1920x1080 {ViewPortIn=1920x1215,ViewPortOut=1900x1060+10+10}"

#Start Discord without blocking the terminal
nohub discord &

#Delay 7.5s
sleep 7.5

#Kill it with pkill function
pkill Discord

#Lastly, load my color profile
sh -c '/usr/bin/nvidia-settings --load-config-only'

This works, but eats 200mb more ram in the startup, but that's fine.

Oh, and I like to attach this image in case someone sees this and have an idea on what is really going on:
image

Will this case be marked as 'Solved'?

1 Like

Great that you found a workaround :). You can mark it solved, if you find a better solution you can always switch 'solved' later.

regards.