Display mode locked at 640x480 and can't change it

I'm trying to install Zorin lite 15.3 (64 bit) on old PC. It has an old Nvidia graphics card. I've tried to install both the Nvidia and non-Nvidia versions of the system and each time the display is set to 640x480 and can't be changed in the Systems menu. The PC does support higher resolutions than this. Any help would be appreciated. Thanks.

What nvidia card are you using ?

It's an Nvidia GF116, Geforce GTX 550 Ti.

What driver did you select in zorin ? because last known drivers for that card are the 390 drivers.

1 Like

It installed a generic driver - I needed to delete the existing drivers to have the "Additional Drivers" section of software update show the available choices. I installed the 390 series that you recommended and it worked. The resolution is now 1366x768 the way it's supposed to be. Thank you very much Michel.


If you think your problem is solved, please mark the thread as "solved" by ticking :ballot_box_with_check:
This will help the future visitors to find the answer they are looking for.

Anytime :smiley:

Good job Michel, this is one of those times where you actually impress us with your helpfulness. Thank you!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.