Display not fitting on my monitor

Are you using an older laptop?

You may want to use an older kernel, reboot and select a different kernel

My laptop is 9 years old, how do I do that?

What do you mean

Please open a terminal with ctrl+alt+t or from the app menu and paste in

sudo lshw -C video

And copy and paste the output here to this thread.

1 Like

Here

i915 driver and all other settings look correct.
Is the Monitor an OLED, LED, LCD or CRT?
Is it connected with HDMI, DP or VGA?

I think it’s an led, it’s connected via VGA

Are you using a straight VGA cable or an adapter to lead VGA to HDMI or other?

On second thought I’m not sure whether I’m using vga or hdmi I connect my monitor cable to my laptop

So far, your settings look correct and your driver is accounted for in the Linux Kernel.
This leads us to investigate possible connection issue.
Can you please verify your cable and connection. If Possible, try using a different cable or even - turning the cable around (If HDMI). Some HDMI Cables are One Way.

1 Like

Use the OSD tool for the monitor, and look at the options for the monitor. You could do a factory reset as well. At a minimal look at Source Control, and Image Control. In Image Control you have a scaling option you can check.

In Source Control, set the interface for the type you are using. Do not use the Auto feature.

2 Likes

Usually this problem can be fixed changing the external monitor settings, with its buttons on the monitor itself. For example, sometimes I plug a laptop to tv by VGA cable and if I set Phase setting from 1 to 30 on tv settings the screen goes off the right edge according to the set value. I found this Clock and phase - Lagom LCD test if you want to check.