Display resolution failure

So I have a twin monitor setup on my desk one is HDMI@1080x1960
and the other is a displaylink over USB which is 600x900.
They have worked just fine for the last week or so that I have had them out to dock to (I have been super busy so I ended up needing more then just the laptop display but I usually don't have them out).
Until last night...
Last night I pluged them into my sleeping laptop and woke it up and loged in and as soon as it booted to gnome shell the HDMI HD monitor changed res to 600x900... I messed with it a bit and now it is worse it thinks it is even smaller then that (I can't remember exactly what size it thought it was) and the laptop monitor is all messed up too. In the resolution drop down in the display settings it says that it is still 1080x1960 but in the little box up top there you rearrange the location of the displays it it showing the smaller res. It also tells me that "due to hardware limitations" it can't be changed to any other res...
I should also add that the 600x900 displaylink screen worked just fine during all this and the HDMI monitor was do it only when the displaylink was plugged in.
I only have one display output from my laptop so I had no way to test if it was the displaylink drivers at fault or not but I uninstalled them, rebooted, and reinstalled them and it did not fix anything. And that brings me to one other thing, this is persistent across reboots so what ever it is it is permanently broken till I figure out how to fix it.

I really appreciate any input. I have time sensitive work I really need the monitors for and I know basically nothing about the technology that makes them work (I have been using Linux as a daily driver though for 7+ years now so I can run command if I need to :wink:).
Thanks in advance! -Ace.

Did you have a recent kernel update before this went sideways?

See if this helps:

It is possible. I have that on auto update. I will look and see what i am running later this evening. Thanks.

Gday @FailurePoint

Not a good idea as this can cause hardware failure.

To check your latest firmware installed,

uname -a

To see all firmware,

apt list --installed | grep linux-image

Please also run this & display the result here.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.