Display resolution problem

Hey guys,
I have an older computer here, that I've installed Zorin on, and the system only shows that the highest resolution I can set it to output is 1024x768, despite hw being capable of HD at least, and monitor being 4k. I suspect it's because of the VGA2HDMI converter I had to use, but still a problem and pain to look at.
Is there any way to have the system recognize the monitor and offer higher resolution, or force it to use higher resolution?
Would be grateful for any help...

Hi Kormiii

And we should know which one ? Without this info there is not much we can do.

Probably your system runs on the open source driver called nouveau

As @Michel asks, please provide more details of your hardware, especially graphics board/chipset.

Also, could you please edit your forum profile to indicate which edition (Pro, Core, Lite etc) of ZorinOS you are using. That will help us help you.

Hey Michel,
thanks for trying to help.
The computer is MSI Wind Nettop 120 (this one: https://www.newegg.com/msi-wind-nettop-120-student-home-office/p/N82E16883152008).
About the driver, how do I find out and possibly install a new one?

Hello Zabadabadoo,
I honestly don't remember which one I installed, this is what I see here:
-Version-
Kernel : Linux 5.15.0-56-generic (x86_64)
Version : #62~20.04.1-Ubuntu SMP Tue Nov 22 21:24:20 UTC 2022
C Library : GNU C Library / (Ubuntu GLIBC 2.31-0ubuntu9.9) 2.31
Distribution : Zorin OS 16.2
Does that help?

Update: looking now at what is available, I definitely installed the Lite version (because of old computer).

Old versions of Ubuntu struggled with GMA950 graphics by Intel. You could try following this guide but no guarantees:

Thanks swarfendor, going to try that now and post an update!

Update: So unfortunately, this did not work. It looks like address for one of the repositories have changed. I have also found similar process on Intel website directly, however with the same result.... :frowning:

Please post the output from this command

sudo lshw -C video

If i am not wrong your gpu should be fully supported by linux since kernel 5.4

Please edit your profile to indicate you have "Lite". Thanks.

*-display
description: VGA compatible controller
product: 82945G/GZ Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:16 memory:fe980000-fe9fffff ioport:dc00(size=8) memory:e0000000-efffffff memory:fe940000-fe97ffff memory:c0000-dffff

See if the post with 7 votes helps:

Failing this you might want to give Zorin 15.3 Lite a try (Zorin OS - Browse /15 at SourceForge.net). If still no luck I would give Antix or MX-Linux a try. I had to install the latter on my good lady's PC I built in 2006!